blob: 31542fd9724bdd1292bda4b88bcd195082af9917 [file] [log] [blame]
2020.08.1, released October 12th, 2020
Important / security related fixes.
Fixes for various compilation issues with GCC 10.x.
meson: Correct SDK cross-compilation.conf file when
per-package builds were used to build SDK.
systemd: Use /run rather than /var/run for PID files in units.
Toolchain: use Secure-PLT rather than BSS-PLT for PowerPC 32.
Fakeroot scripts (BR2_ROOTFS_POST_FAKEROOT_SCRIPT) are now run
after all finalization hooks (including pre-rootfs) to ensure
they can override any late configuration done by packages.
support/script/pycompile: Rework logic to ensure .pyc files
contain absolute target paths, fixing code inspection at
runtime when executed with cwd != '/'.
support/scripts/setlocalversion: Correct Mercurial output to
match behaviour with Git.
support/scripts/apply-patches.sh: Use patch
--no-backup-if-mismatch, so we no longer blindly have to
remove *.orig files after patching, fixing issues with
packages containing such files.
fs/jffs2: Now correctly handles xattrs
Updated/fixed packages: acpica, afboot-stm32, alsa-utils,
apparmor, bandwidthd, barebox, bash, bison, brotli,
cifs-utils, cups, dhcpcd, dhcpdump, docker-cli, docker-engine,
ecryptfs-utils, efl, fail2ban, fbterm, ffmpeg, fontconfig,
freetype, gcc, gdb, ghostscript, gnupg2, gnutls, go, gqview,
gst1-plugins-base, gst1-plugins-ugly, ipmitool, jbig2dec,
kexec, lcdproc, libcamera, libhtp, libnetconf2, libraw,
libssh, libxml2, libxml-parser-perl, libzip, linux-headers,
live555, localedef, ltp-testsuite, lua, matchbox, memcached,
memtester, mesa3d, meson, minidlna, mongodb, mongrel2, motion,
mraa, mtd, musepack, neardal, netatalk, netperf, netsniff-ng,
nginx, nodejs, nss-pam-ldapd, open-plc-utils, openswan,
opentyrian, openvmtools, php, postgresql, python,
python-aenum, python-cycler, python-engineio, python-fire,
python-pymodbus, python-scapy, python-semver,
python-sentry-sdk, python-socketio, python-texttable,
python-tinyrpc, python-txtorcon, python3, qt5base, quagga,
read-edid, redis, rsh-redone, runc, samba4, socketcand,
strace, supertux, suricata, systemd, ti-utils, trinity,
uclibc, usb_modeswitch, vlc, vsftpd, wampcc,
wayland-protocols, wireguard-linux-compat, wireshark, wlroots,
wolfssl, w_scan, xerces, xfsprogs, xdriver-xf86-video-ati,
xserver_xorg-server, ympd, zeromq, zlib-ng, zstd
Issues resolved (http://bugs.uclibc.org):
#12911: usb_modeswitch installation race condition
#13236: Can't compile linux 5.4.8 (with gcc 10 on host)
2020.08, released September 1st, 2020
Various fixes.
Updated/fixed packages: am33x-cm3, avahi, bluez-tools,
busybox, chocolate-doom, collectd, dhcp, docker-cli, domoticz,
gobject-introspection, graphite2, haproxy, ibm-sw-tpm2,
imagemagick, libeXosip2, libressl, lxc, mbedtls, menu-cache,
mongodb, mosquitto, nvidia-driver, paho-mqtt-c, pixz,
postgresql, python-django, rtty, squid, stress-ng, systemd,
trousers, uclibc, wireshark, wolfssl, zbar
2020.08-rc3, released August 28th, 2020
Fixes all over the tree.
Infrastructure: Ensure RPATH entries that may be needed for
dlopen() are not dropped by patchelf.
Toolchain: Drop old GCC 6 based external Sourcery AMD64
toolchain.
Updated/fixed packages: assimp, davfs2, dillo, glibc,
gnuradio, hostapd, ibm-sw-tpm2, ipmitool, json-c, libroxml,
linux, mender, netopeer2, openal, openjpeg, python-matplotlib,
ripgrep, shadowsocks-libev, trousers, xlib_libX11,
xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#13141: Target-finalize fail with "depmod: ERROR: Bad version passed"
2020.08-rc2, released August 24th, 2020
Fixes all over the tree, including a number of fixes for
compilation with GCC-10.
Toolchain: Disallow building uClibc-ng for RISC-V 64-bit,
because of issues with a missing __riscv_flush_icache()
implementation.
Defconfigs: CI20: Use mainline Linux and U-boot. Update
Microchip sama5d27_wlsom1_ek_mmc_dev to use bluez5-utils
instead of (the removed) legacy bluez-utils
Updated/fixed packages: 18xx-ti-utils, aircrack-ng, apache,
atest, bandwidthd, bellagio, bind, bird, bluez-alsa, boost,
c-periphery, capnproto, chrony, collectd, cpio, cvs,
dieharder, domoticz, dovecot, dovecot-pigeonhole, drbd-utils,
dump1090, efl, elixir, f2fs-tools, feh, fluidsynth, fping,
gdbm, gdk-pixbuf, ghostscript, gst1-plugins-bad,
gstreamer1-editing-services, htop, ibm-sw-tpm2, ifplugd,
iftop, igd2-for-linux, ima-evm-utils, iprutils, iputils,
keepalived, kmsxx, libabseil-cpp, libcamera, libcurl,
libfuse3, libnss, librtlsdr, libubox, libunwind, live555,
lttng-tools, luabitop, mender-artifact, minizip,
mjpg-streamer, mpd, mpv, mtd, ncftp, open-lldp, openal,
opencv, opencv3, openfpgaloader, optee-os, owfs, php,
pistache, prosody, pulseview, python-decorator,
python-gunicorn, python-rpi-gpio, python-spidev,
python3-decorator, python3-mako, python3-pyselftools, qt5,
qt5webengine, rauc, redis, ripgrep, rtl8188eu, rtl8821au,
setools, smstools3, supertux, tftpd, tpm2-abrmd,
wpa_supplicant, xen, xlib_libX11, xserver_xorg-server
New packages: python3-cython, python3-pycryptodomex
Issues resolved (http://bugs.uclibc.org):
#12876: nodejs fails to build when host-icu has been built before
#13111: python-gunicorn: missing dependency on python-setuptools
#13121: wpa_supplicant fails to build without libopenssl enabled
#13146: raspberrypi3_defconfig: "Inappropriate ioctl for device"..
#13156: package live555 new license
#13166: python-rpi-gpio: does not work against aarch64, unint..
2020.08-rc1, released August 6th, 2020
Toolchain:
- GCC 10.x added, GCC 9.x is the default
- binutils 2.34 added, binutils 2.33 is the default, binutils
2.31 removed
- glibc updated to 2.31
- ARC toolchain components updated to 2020.03-release.
- Enable uClibc-ng usage for RISC-V 64-bit
Infrastructure:
- qmake-package was fixed to be compatible with
BR2_PER_PACKAGE_DIRECTORIES
- complete rewrite of the Gitlab CI Yaml configuration file,
now generated directly by the Gitlab CI pipeline itselfs
Misc:
- cargo and cargo-bin packages removed, as cargo is now part
of Rust itself
Filesystem: ubinize configuration files can now use
BINARIES_DIR to refer to the $(O)/images directory.
New packages: bitwise, earlyoom, fuse-overlayfs, gloox,
kodi-pvr-octonet, kodi-pvr-zattoo, libabseil-cpp, libcutl,
libnids, libnpupnp, libodb, libodb-boost, libodb-mysql,
libodb-pgsql, mbpfan, netopeer2, odb, parprouted,
python-colorzero, python-gpiozero, python-pybind, python-yatl,
python3-decorator, qt5quicktimeline, resiprocate, ttyd,
unclutter-xfixes, urandom-scripts,
New defconfigs: bananapi_m2_zero, freescale_imx8mnevk,
globalscale_espressobin, imx6ullevk,
microchip_sama5d27_wlsom1_ek, rock_pi_4, rock_pi_n10
Removed packages: cargo, cargo-bin,
kodi-peripheral-steamcontroller
Issues resolved (http://bugs.uclibc.org):
#12941: Python GObject fails to build when using BR2_PER_PACKAGE_DIRECTORIES
#12946: Grub: Decompressor is too big.
#12986: Mtools: Error converting to codepage 850
#13001: openjdk-bin replaces libfreetype.so from host-freetype
#13011: Incorrect selection of gcc version
#13021: Minor code error when building granite-0.4.1
#13026: rpi-firmware: must not rename start files
#13046: Optimize for fast -Ofast is not compliant
#13081: host-e2fsprogs attempts to create udev rules.d on build host if not exists
#13101: BR audit2allow support
2020.05.3, released October 12th, 2020
Important / security related fixes.
meson: Correct SDK cross-compilation.conf file when
per-package builds were used to build SDK.
systemd: Use /run rather than /var/run for PID files in units.
Toolchain: use Secure-PLT rather than BSS-PLT for PowerPC 32.
Fakeroot scripts (BR2_ROOTFS_POST_FAKEROOT_SCRIPT) are now run
after all finalization hooks (including pre-rootfs) to ensure
they can override any late configuration done by packages.
support/script/pycompile: Rework logic to ensure .pyc files
contain absolute target paths, fixing code inspection at
runtime when executed with cwd != '/'.
support/scripts/setlocalversion: Correct Mercurial output to
match behaviour with Git.
support/scripts/apply-patches.sh: Use patch
--no-backup-if-mismatch, so we no longer blindly have to
remove *.orig files after patching, fixing issues with
packages containing such files.
Updated/fixed packages: alsa-utils, apparmor, avahi,
bandwidthd, barebox, bash, bison, brotli, busybox, cifs-utils,
cryptsetup, cups, dhcpcd, dhcpdump, docker-cli, docker-engine,
ecryptfs-utils, efl, fail2ban, freetype, gcc, gdb,
ghostscript, gnutls, go, graphite2, gst1-plugins-base,
gst1-plugins-ugly, imagemagick, ipmitool, jbig2dec, libhtp,
libraw, libssh, libxml2, libxml-parser-perl, linux-headers,
localedef, lua, mbedtls, memcached, mesa3d, meson, minidlna,
mongodb, nginx, nodejs, nss-pam-ldapd, openvmtools,
paho-mqtt-c, php, postgresql, python, python-aenum,
python-django, python-engineio, python-fire, python-pymodbus,
python-scapy, python-semver, python-sentry-sdk,
python-socketio, python-texttable, python-tinyrpc,
python-txtorcon, python3, qt5base, rsh-redone, runc, samba4,
strace, supertux, suricata, systemd, uclibc, usb_modeswitch,
vlc, vsftpd, wayland-protocols, wireguard-linux-compat,
wireshark, wlroots, wolfssl, xserver_xorg-server, ympd,
zeromq, zstd
Issues resolved (http://bugs.uclibc.org):
#12911: usb_modeswitch installation race condition
#13251: cryptsetup does not work on branch 2020.02 following..
2020.05.2, released August 29th, 2020
Important / security related fixes.
Infrastructure: Ensure RPATH entries that may be needed for
dlopen() are not dropped by patchelf.
BR_VERSION_FULL/setlocalversion (used by make print-version
and /etc/os-release): Properly handle local git tags
Updated/fixed packages: apache, assimp, at91bootstrap3, bind,
boost, busybox, capnproto, cegui, chrony, collectd, cpio,
cryptsetup, cups, cvs, dbus, docker-engine, domoticz, dovecot,
dovecot-pigeonhole, dropbear, efl, elixir, f2fs-tools, ffmpeg,
gd, gdk-pixbuf, ghostscript, glibc, gnuradio, grub2,
gst1-plugins-bad, gstreamer1-editing-services, hostapd,
ibm-sw-tpm2, iputils, jasper, json-c, libcurl, libressl,
libwebsockets, linux, live555, mesa3d, mongodb, mosquitto,
mpv, nodejs, opencv, opencv3, openfpgaloader, openjpeg,
patchelf, perl, php, postgresql, prosody, python-django,
python-gunicorn, python-matplotlib, ripgrep, rtl8188eu,
rtl8821au, ruby, shadowsocks-libev, squid, systemd,
tpm2-abrmd, tpm2-tools, trousers, uboot, webkitgtk, wireshark,
wolfssl, wpa_supplicant, wpewebkit, xen, xlib_libX11,
xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#12876: nodejs fails to build when host-icu has been built before
#13111: python-gunicorn: missing dependency on python-setuptools
#13121: wpa_supplicant fails to build without libopenssl enabled
#13141: Target-finalize fail with "depmod: ERROR: Bad version passed"
#13156: package live555 new license
2020.05.1, released July 25th, 2020
Important / security related fixes.
Toolchain:
- Make external toolchain version check also work for
toolchains configured with --with-gcc-major-version-only
- Do not handle SOURCE_DATE_EPOCH in toolchain wrapper if the
compiler supports it, fixing an issue with precompiled
headers
- Ensure debug libs from external toolchains are not installed
into target if debugging is disabled
Download:
- Correct reproducibility issue in handling of git submodules
for older git versions.
- Fix file locking over NFS
fs: Ensure cpio archive element order is reproducible
Br2-external: Fix error reporting for invalid br2-external trees
Per-package:
- Fix an issue with python3 sysconfig data not getting
correctly expanded
- Fix per-package building for packages using the qmake
infrastructure
Updated/fixed packages: a10disp, asterisk, bind, brltty,
cdrkit, clamav, cryptodev-linux, dbus, docker-cli,
docker-engine, dvb-apps, e2fsprogs, exim, exiv2, freerdp, gdb,
gdk-pixbuf, gerbera, gnutls, go, granite, grub2, gssdp,
gst1-plugins-good, gst1-plugins-ugly, gupnp, intel-microcode,
iproute2, irrlicht, iwd, jq, kodi, libcamera, libcec,
libconfuse, libcurl, libevdev, libhttpserver, libmicrohttpd,
libnss, libressl, libvncserver, libxml2, libxmlrpc, lxc,
mbedtls, mediastreamer, mesa3d, meson, minizip, mongodb,
mtools, mutt, nano, network-manager, nghttp2, ngircd, nodejs,
ntp, open-plc-utils, open2300, openjdk-bin, openssh,
oracle-mysql, paho-mqtt-c, pango, php, poco, prosody, putty,
python-greenlet, python-urllib3, python-validators, python3,
readline, redis, rpi-firmware, rtl8821au, samba4, sdl2,
sqlite, squid, strace, sunxi-mali-mainline-driver, syslog-ng,
systemd, tcpreplay, tinydtls, upmpdcli, upx, vlc, webkitgtk,
wireguard-linux-compat, wireshark, wpebackend-fdo, wpewebkit,
x11vnc, znc, zstd
Issues resolved (http://bugs.uclibc.org):
#12941: Python GObject fails to build when using BR2_PER_PACKAGE_..
#12946: Grub: Decompressor is too big.
#12986: Mtools: Error converting to codepage 850
#13001: openjdk-bin replaces libfreetype.so from host-freetype
#13011: Incorrect selection of gcc version
#13021: Minor code error when building granite-0.4.1
#13026: rpi-firmware: must not rename start files
#13031: nodejs: RangeError at new ArrayBuffer()
#13046: Optimize for fast -Ofast is not compliant
2020.05, released June 1st, 2020
Various fixes.
Updated/fixed packages: arm-trusted-firmware, gcc, mp4v2, fmc,
fmlib, glib-networking, libusb-compat, linux, qt5webengine,
sysrepo, wampcc, xen
2020.05-rc3, released May 29th, 2020
Fixes all over the tree.
Infrastructure: Support checking download hashes for packages
coming from Subversion.
Defconfigs: Increase boot partition size to 64MB for Freescale
boards to allow space for bigger kernels.
Updated/fixed packages: audit, bind, dovecot, efl, erlang,
ffmpeg, fio, gerbera, gnupg, leveldb, lrzip, ltrace, matio,
mesa3d, mp4v2, prosody, qemu, qt5declarative, speexdsp,
systemd, tremor, uboot-tools, unbound, wireshark
Removed packages: wiringpi
Issues resolved (http://bugs.uclibc.org):
#12361: Init system (systemd) kills login on Raspberry Pi Zero
#12686: recipe for target 'install_dev' failed (libcrypto.so..)
2020.05-rc2, released May 22nd 2020
Fixes all over the tree.
U-Boot: Support building with Python 3.x instead of Python
2.x. Since U-Boot 2020.01, various U-Boot build scripts use
Python 3.x instead of Python 2.x, so add an option to pull in
host-python3 rather than host-python. Also fix a number of
defconfigs to use this new option.
Updated/fixed packages: apparmor, binutils, bison, brltty,
c-icap, cegui, checkpolicy, clamav, crda, cvs, docker-cli,
docker-engine, domoticz, elf2flt, exfatprogs, fakeroot,
ffmpeg, freerdp, gcc, glibc, gnuconfig, irrlicht, kmod,
libexif, libpam-tacplus, libssh2, libv4l, libvncserver,
localedef, lrzip, mariadb, matchbox, mbuffer, mesa3d,
mesa3d-headers, meson, netsniff-ng, openldap, openocd,
optee-os, p7zip, paho-mqtt-c, php, piglit, pigz,
python-argon2-cffi, python-attrs, python-future,
python-markdown, python-pycryptodomex, python-pyqt5, qt5base,
rpi-firmware, rustc, squashfs, squid, stella, suricata,
systemd, uacme, uclibc, util-linux, vboot-utils
New packages: python3-pyelftools
Removed packages: ezxml, mtdev2tuio, python-pycrypto
Issues resolved (http://bugs.uclibc.org):
#10551: PowerPC SPE and Musl
#12256: package tar is outdated (1.29 is 3 years old)
#12271: python-iptables runtime dependencies
#12321: host-generic-package: PKG_DL_OPTS not used for host package
#12391: CMake-based host package fails to include output/host/include
#12431: ethernet no detected on nanopi neo 2
#12521: RISCV RV32IA selected, RV64GC output
#12586: avahi failure
#12596: host-e2fsprogs: tune2fs incompatibility on older glibc..
#12611: ntp hash is not matching with upstream 4.2.8p13
#12626: PHP missing header files within 2020.02
#12631: glibc support Power-PC SPE
#12656: bison fails to relocate with relocate-sdk.sh
#12661: cups problems in buildroot
#12686: recipe for target 'install_dev' failed (libcrypto.so:..
#12691: host-rust build fails
#12761: Buildroot fails when building GCNano binaries for the STM..
#12786: Systemd spawns two getty processes when the getty port..
#12806: There are multiple issues in buildroot that faults cups..
#12826: nodejs-12.16.1: error: 'uv_sleep' was not declared in..
#12831: RPI-firmware package: DTB-overlay dependency
#12836: libunwind: package does not show up in menuconfig for..
#12841: util-linux/sfdisk 2.35.1 fails on sector-size header
#12866: should we be disabling bash executable path caching?
#12886: GMP built in wrong order (?)
#12891: QEMU, libvirt-bin, qemu-kvm Package Support required
#12901: GStreamer doesn't build on 2020-05 rc1 with GObject..
#12906: qt PrefixPath is wrong on 2020.05-rc1
#12921: nodejs-12.16.1: error: overriding 'virtual icu_65::..
2020.05-rc1, released May 7th 2020
Addition of support for gobject-introspection: both the
gobject-introspection package itself, but also introspection
support was enabled in a number of other packages.
Support for Qt 5.6 was dropped as its support was dropped
upstream, only one version of Qt is supported at the moment:
Qt 5.14.2.
Addition of support for the apparmor Linux security module, by
adding the necessary user-space packages.
Addition of a qmake package infrastructure, now used by most
Qt-related packages.
The Luarocks package infrastructure has been extended to
support build host packages.
The package infrastructure was improved to allow each package
to indicate the Linux kernel configuration options it needs.
Addition of support for generating filesystem images using the
EROFS filesystem.
The logic that calculates the list of files installed by each
package was reworked to be compatible with the top-level
parallel build functionality.
Addition of a package for a pre-compiled ARM32 bare-metal
toolchain, which can be used to build ARM32 code in ARM64
configurations, such as firmware/bootloader code.
The Qemu defconfigs are now boot-tested in Qemu as part of the
Gitlab continuous integration.
Toolchain: gcc 9.x bumped to 9.3.0, gcc 8.x bumped to 8.4.0,
gdb bumped to 8.3.1.
New packages: apcupsd, apparmor, arm-gnu-a-toolchain, bearssl,
belle-sip, belr, cage, chartjs, erofs-utils, exfatprogs,
gobject-introspection, ibm-sw-tpm2, imx-seco, jbig2dec,
libapparmor, libiberty, libfuse3, libtextstyle, libudfread,
libuhttpd, libuwsc, lua-lyaml, matio, mbuffer, netdata,
openfpgaloader, perl-i18n, perl-locale-maketext-lexicon,
perl-lwp-protocol-https,
perl-mojolicious-plugin-authorization,
perl-mojolicious-plugin-cspheader,
perl-mojolicious-plugin-i18n,
perl-mojolicious-plugin-securityheader, perl-mozilla-ca,
perl-path-class, pistache, pkcs11-helper, prelink-cross,
python-argon2-cffi, python-canopen, python-cbor2,
python-filelock, python-flatbuffers, python-greenlet,
python-modbus-tk, python-pyalsa, python-pysftp, python-regex,
python-snappy, rtty, tinyproxy, udev-gentoo-scripts, unbound,
vuejs, wlroots.
New defconfigs: freescale_imx6ullevk, freescale_imx8qmmek,
nanopi_neo4, nanopi_r1, nitrogen8mm, nitrogen8mn, olpc_xo1,
olpc_xo175, roc_rk3399_pc, stm32mp157a_dk1, zynq_qmtech
Issues resolved (http://bugs.uclibc.org):
#10386: Add an option to put all compiled executables that
show up on target/ in staging/ as well
#11866: iniramfs file system fails to boot using Grub on EFI x86_64
#12666: Doesn't pick up a custom bash profile
#12696: Uboot 2020.01 Problem loading Linux kernel on Nano PI NEO
#12701: [patch] wpa_supplicant must depend on openssl
#12711: host-localedef 2.30-20 fails to compile on fedora 32 (gcc 10.0.1)
#12716: bio.h not found
#12726: systemctl preset-all failed for ctrl-alt-del.target
#12731: rtl8188eu not buildung for banana pi M1 (glib, systemd, 4.18.12)
#12746: "sysdig" package description points to
http://sysdig.org, which bounces to malware site
#12751: OpenJdk package installation issues on target
#12796: Update OpenSSL to Version 1.1.1g to patch CVE-2020-1967
#12811: bootstrap stuck and no login prompt
2020.02.7, released October 12th, 2020
Important / security related fixes.
meson: Correct SDK cross-compilation.conf file when
per-package builds were used to build SDK.
systemd: Use /run rather than /var/run for PID files in units.
Toolchain: use Secure-PLT rather than BSS-PLT for PowerPC 32.
support/script/pycompile: Rework logic to ensure .pyc files
contain absolute target paths, fixing code inspection at
runtime when executed with cwd != '/'.
support/scripts/setlocalversion: Correct Mercurial output to
match behaviour with Git.
support/scripts/apply-patches.sh: Use patch
--no-backup-if-mismatch, so we no longer blindly have to
remove *.orig files after patching, fixing issues with
packages containing such files.
Updated/fixed packages: bandwidthd, barebox, bash, bison,
brotli, cifs-utils, cryptsetup, dhcpcd, dhcpdump, docker-cli,
docker-engine, ecryptfs-utils, efl, fail2ban, freetype, gcc,
gdb, ghostscript, gnutls, go, gst1-plugins-base,
gst1-plugins-ugly, ipmitool, libhtp, libraw, libssh, libxml2,
libxml-parser-perl, localedef, lua, memcached, mesa3d, meson,
minidlna, nginx, nodejs, nss-pam-ldapd, openvmtools, php,
postgresql, python, python-aenum, python-autobahn,
python-engineio, python-fire, python-pymodbus, python-scapy,
python-semver, python-sentry-sdk, python-socketio,
python-texttable, python-tinyrpc, python-txtorcon, python3,
qt5base, runc, samba4, strace, supertux, suricata, systemd,
vlc, wayland-protocols, wireguard-linux-compat, wireshark,
xserver_xorg-server, zeromq, zstd
Issues resolved (http://bugs.uclibc.org):
#12911: usb_modeswitch installation race condition
#13251: cryptsetup does not work on branch 2020.02 following..
2020.02.6, released September 5th, 2020
Important / security related fixes.
Fix a 2020.02.5 build regression in busybox when systemd (and
not less) are enabled because of missing infrastructure.
Updated/fixed packages: alsa-utils, avahi, busybox, cups,
docker-cli, graphite2, imagemagick, libeXosip2, mbedtls,
nvidia-driver, paho-mqtt-c, python-django, systemd, uclibc,
usb_modeswitch, wolfssl
Issues resolved (http://bugs.uclibc.org):
#12911: usb_modeswitch installation race condition
2020.02.5, released August 29th, 2020
Important / security related fixes.
Infrastructure: Ensure RPATH entries that may be needed for
dlopen() are not dropped by patchelf.
BR_VERSION_FULL/setlocalversion (used by make print-version
and /etc/os-release): Properly handle local git tags
Updated/fixed packages: apache, at91bootstrap3, bind, boost,
busybox, capnproto, chrony, collectd, cpio, cryptsetup, cups,
cvs, dbus, docker-engine, domoticz, dovecot,
dovecot-pigeonhole, dropbear, efl, elixir, f2fs-tools, ffmpeg,
gd, gdk-pixbuf, ghostscript, glibc, grub2, gst1-plugins-bad,
hostapd, iputils, jasper, json-c, libcurl, libwebsockets,
linux, live555, mesa3d, mosquitto, mpv, nodejs, opencv,
opencv3, openjpeg, patchelf, perl, php, postgresql,
python-django, python-gunicorn, python-matplotlib, ripgrep,
rtl8188eu, rtl8821au, ruby, shadowsocks-libev, squid,
tpm2-abrmd, tpm2-tools, trousers, uacme, webkitgtk, wireshark,
wolfssl, wpa_supplicant, wpewebkit, xen, xlib_libX11,
xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#12876: nodejs fails to build when host-icu has been built before
#13111: python-gunicorn: missing dependency on python-setuptools
#13121: wpa_supplicant fails to build without libopenssl enabled
#13141: Target-finalize fail with "depmod: ERROR: Bad version passed"
#13156: package live555 new license
2020.02.4, released July 26th, 2020
Important / security related fixes.
Toolchain:
- Make external toolchain version check also work for
toolchains configured with --with-gcc-major-version-only
- Do not handle SOURCE_DATE_EPOCH in toolchain wrapper if the
compiler supports it, fixing an issue with precompiled
headers
- Ensure debug libs from external toolchains are not installed
into target if debugging is disabled
Download:
- Correct reproducibility issue in handling of git submodules
for older git versions.
- Fix file locking over NFS
fs: Ensure cpio archive element order is reproducible
Br2-external: Fix error reporting for invalid br2-external trees
Per-package:
- Fix an issue with python3 sysconfig data not getting
correctly expanded
- Fix per-package building for packages using the qmake
infrastructure
Updated/fixed packages: a10disp, asterisk, bind, cdrkit,
checkpolicy, clamav, dbus, docker-cli, docker-engine,
dvb-apps, e2fsprogs, exim, exiv2, freerdp, gnutls, go, grub2,
gssdp, gst1-plugins-good, gst1-plugins-ugly, gupnp,
intel-microcode, iproute2, irrlicht, iwd, jq, kodi, libcamera,
libconfuse, libcurl, libglib2, libhttpserver, libmicrohttpd,
libopenssl, libvncserver, libxml2, libxmlrpc, lxc, mbedtls,
mesa3d, meson, mongodb, mtools, mutt, nghttp2, ngircd, nodejs,
ntp, open-plc-utils, open2300, openjdk-bin, openssh,
oracle-mysql, paho-mqtt-c, pcre, php, poco, prosody, putty,
python-twisted, python-urllib3, python-validators, python3,
qt5xmlpatterns, redis, rpi-firmware, rtl8821au, samba4, sdl2,
sqlite, squid, syslog-ng, systemd, tcpreplay, tinydtls,
upmpdcli, upx, vlc, webkitgtk, wireguard-linux-compat,
wireshark, wpebackend-fdo, wpewebkit, zstd
Issues resolved (http://bugs.uclibc.org):
#12941: Python GObject fails to build when using BR2_PER_PACKAGE_..
#12946: Grub: Decompressor is too big.
#12986: Mtools: Error converting to codepage 850
#13001: openjdk-bin replaces libfreetype.so from host-freetype
#13011: Incorrect selection of gcc version
#13026: rpi-firmware: must not rename start files
#13031: nodejs: RangeError at new ArrayBuffer()
#13046: Optimize for fast -Ofast is not compliant
2020.02.3, released June 3rd, 2020
Important / security related fixes.
Fix various build issues of host packages on hosts using GCC
10.
Updated/fixed packages: arm-trusted-firmware, audit, bind,
binutils, bison, clamav, crda, dovecot, dtc, efl, elf2flt,
erlang, fakeroot, ffmpeg, fmc, fmlib, freerdp, gcc, git,
glib-networking, gnupg, leveldb, libexif, libssh2,
libusb-compat, linux-headers, lrzip, ltrace, mariadb, mesa3d,
mp4v2, openldap, openocd, perl, php, prosody,
python-pycryptodomex, python-pyqt5, qemu, rpi-firmware, rustc,
speexdsp, sysrepo, systemd, tremor, vboot-utils, wireshark,
xen
Removed packages: python-pycrypto
Issues resolved (http://bugs.uclibc.org):
#12361: Init system (systemd) kills login on Raspberry Pi Zero
#12656: bison fails to relocate with relocate-sdk.sh
#12671: leveldb won't detect that snappy is present (static..
#12691: host-rust build fails
#12831: RPI-firmware package: DTB-overlay dependency
2020.02.2, released May 12th, 2020
Important / security related fixes.
Musl: Disallow on PPC64 cores without AltiVec support
(E.G. e5500).
fs/cpio: Correctly handle booting with 'console='
release: Ensure temporary .br2-external.* files are not
included in the release tarball
Defconfigs: Fix various mistyped config options, or config
options where the dependencies were no longer met.
Updated/fixed packages: apache, azure-iot-sdk-c, binutils,
boinc, c-ares, cvs, docker-cli, docker-containerd,
docker-engine, domoticz, e2fsprogs, efl, evtest, exim, ffmpeg,
freerdp, gcc, gflags, glibc, gnuconfig, haproxy, imx-gpu-2d,
irrlicht, jpeg kodi-pvr-vuplus, libarchive, libcoap,
libfpm-extra, libglib2, libhtp, libid3tag, libinput, libmad,
libopenssl, libsepol, libssh, libv4l, libvncserver, libwpe,
localedef, mariadb, matchbox, mbedtls, mc, mesa3d-headers,
meson, midori, msgpack, netsnmp, nginx, ogre, openjdk,
openldap, openvpn, p7zip, paho-mqtt-c, php, polkit, python,
python-attrs, python-crossbar, python-dpkt, python-flask,
python-future, python-iptables, python-jedi, python-markdown2,
python3, qemu, qpdf, qt5, samba4, squashfs, squid, strongswan,
suricata, tzdata, util-linux, vlc, wget, webkitgtk,
wireguard-linux-compat, wireshark, wpebackend-fdo, wpewebkit,
zic
Issues resolved (http://bugs.uclibc.org):
#11866: initramfs file system fails to boot using Grub on EFI x86_64
#12271: python-iptables runtime dependencies
#12726: systemctl preset-all failed for ctrl-alt-del.target
#12751: OpenJdk package installation issues on target
#12796: Update OpenSSL to Version 1.1.1g to patch CVE-2020-1967
#12811: bootstrap stuck and no login prompt
#12841: util-linux/sfdisk 2.35.1 fails on sector-size header
2020.02.1, released April 10th, 2020
Important / security related fixes.
core: Also fixup /lib references in libtool .la files, similar
to how it is done for /usr/*.
Various fixes for builds with per-package target/host
directories.
toolchain: Fix kernel headers validation check for external
toolchains. Fix make 4.3+ compatibility in external toolchain
logic.
fs/initramfs: fix show-info so it also shows the usual
rootfs-related variables.
Updated/fixed packages: arm-trusted-firmware, barebox-aux,
bluez5_utils, bubblewrap, busybox, civetweb, cog, collectd,
ffmpeg, gcc, gnutls, gssdp, gvfs, haproxy, hiredis, hostapd,
kmscube, kodi-screensaver-rsxs, libical, libinput, libexif,
libopenssl, libsndfile, linux, linux-tools, llvm, localedef,
mcrypt, mesa3d, meson, monit, nftables, ntp, opencv3,
oprofile, php, pinentry, polkit, pure-ftpd, python-pyyaml,
qt5, quagga, radvd, rcw, redis, rocksdb, samba4, screen,
sdbusplus, swupdate, sysdig, sysklogd, syslinux, syslog-ng,
tor, tslib, uacme, util-linux, vala, vlc,
wireguard-linux-compat, wireguard-tools, wireshark,
wpa_supplicant, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#12711: host-localedef 2.30-20 fails to compile on fedora 32
#12746: "sysdig" package description points to http://sysdig.org, ..
2020.02, released March 8th, 2020
Various fixes.
br2-external: Fix compatibility with make 4.3+
Updated/fixed packages: bash, bcm2835, binutils, cups,
erlang-p1-acme, fbgrab, gr-osmosdr, gst1-plugins-base,
gst1-validate, gstreamer1, guile, jhead, libdrm, libevdev,
libinput, libnss, libsndfile, libvncserver, linux-firmware,
mesa3d, nodejs, openjdk-bin, openvmtools, optee-test, patch,
php, piglit, pppd, python-django, qemu, qt5base, ruby,
ser2net, swupdate, thrift, zziplib
Removed packages: classpath, jamvm
Issues resolved (http://bugs.uclibc.org):
#12606: fbgrab location has changed
2020.02-rc3, released March 2nd, 2020
Fixes all over the tree.
Infrastructure: Rework file list handling to fix race
conditions when building with per-package target and host
directories and top-level parallel builds.
Updated/fixed packages: aufs, binutils, blktrace, brltty,
cairo, dnsmasq, docker-compose, elf2flt, exim, exiv2, git,
kodi-inputstream-adaptive, libarchive, libcgroup, libgdiplus,
libssh2, libvncserver, libvorbis, linknx, linux-firmware, lxc,
lz4, mosquitto, openjpeg, openrc, poco, proftpd, pure-ftpd,
python3, python-multidict, python-setuptools-scm-git-archive,
qpdf, qt5tools, rdesktop, rocksdb, shellinabox, squid,
suricata, swig, systemd, taglib, util-linux, wireshark, zsh
Issues resolved (http://bugs.uclibc.org):
#12571: ltp-testsuite : Build failure
#12576: 2020.02-RC1: error while loading shared libraries: ...
#12581: 2020.02-rc1 glibc failing to build on fedora 31
2020.02-rc2, released February 26th, 2020
Fixes all over the tree.
Toolchain: Ensure strong SSP can only be enabled if the
(external) toolchain supports it.
Fix a race condition related to creating the output/staging
symlink on systems with coreutils < 8.27.
Drop support for the (end of life) Qt 5.6 variant.
Updated/fixed packages: at, armadillo, audiofile, bash,
busybox, erlang, fail2ban, fluidsynth, ipsec-tools, jpeg-turbo,
kvm-unit-tests, libftdi1, libinput, libsvgtiny, libtomcrypt,
libupnpp, libxml2, linux-tools, luv, mbedtls, mesa3d, minicom,
openvmtools, php, qt5, qt5webengine, qwt, radvd, rcw,
sdbusplus, systemd, tpm2-tss, vorbis-tools
Issues resolved (http://bugs.uclibc.org):
#12581: 2020.02-rc1 glibc failing to build on fedora 31
2020.02-rc1, released February 18th, 2020
Fixes all over the tree and new features.
Add experimental support for building with a per-package
target and host directory. This still has some rough edges,
but brings a number of advantages:
- Packages will only be able to access the explicitly listed
dependencies and not any other packages that happen to be
built before, ensuring correct dependency information in
Buildroot.
- Possibility for top-level parallel builds, speeding up
builds on multicore machines.
Core: Ensure package-file-lists data is correct after
incremental builds as well.
Architecture: Add support for ARC-HS38 with 64bit multiplier
variant, allow building glibc for big endian ARC, handle 16KB
MMU page size for ARC in toolchain wrapper.
Toolchain: Add binutils 2.33.1, GCC 7.5.0, Arm 9.2-2019.12
toolchains, ARC 2019.09 toolchain. Allow using custom kernel
headers newer than what is known by Buildroot.
pkg-stats: Support for CVE vulnerability reporting by
comparing to NVD database.
Reproducible builds: The go -trimpath option is now used to
get rid of absolute build paths, __FILE__ and __BASE_FILE__
defines are now handled in the toolchain wrapper.
Systemd: Build host variant and use systemctl to automatically
enable unit files rather than manually managing symlinks.
Util-linux: Ensure that hwclock is built without GPLv3
code. Notice that builds with hwclock has contained
GPLv3-licensed code since util-linux 2.30 (Buildroot 2017.08+)
New defconfigs: Beelink GS1, Raspberrypi4 64bit
New packages: alura, avro-c, bubblewrap, cctz, cereal,
cpuburn-arm, elixir, erlang-base64url, erlang-idna,
erlang-jose, erlang-p1-acme, erlang-p1-mqtree,
erlang-p1-yconf, fluid-soundfont, fluidsynth, gcnano-binaries,
gensio, glslsandbox-player, libargon2, libmodsecurity,
libpam-nfc, libtelnet, lua-codegen, lua-livr, lua-livr-extra,
lua-rotas, lua-silva, mfoc, network-manager-openvpn,
nginx-modsecurity, perl-crypt-openssl-aes,
perl-math-prime-util, pipewire, ptm2human, python-aenum,
python-aiohttp-debugtoolbar, python-aiohttp-mako,
python-aiologstash, python-aiosignal, python-aiozipkin,
python-async-lru, python-avro, python-bunch, python-crontab,
python-dnspython, python-entrypoints, python-esptool,
python-frozenlist, python-future, python-gitdb, python-janus,
python-lockfile, python-logstash, python-nested-dict,
python-pbr, python-pyaes, python-pydantic, python-smmap2,
python-sockjs, python-zc-lockfile, raspi-gpio, rocksdb,
sdbusplus, spidermonkey, thermald, ti-sgx-libgbm, tinyssh,
tio, umtprd, weston-imx, wireguard-linux-compat,
wireguard-tools, xdg-dbus-proxy
Removed packages: bluez_utils, celt051, erlang-p1-iconv, fis,
gadgetfs-test, libplayer, gstreamer, gst-ffmpeg,
gst-fsl-plugins, gst-omapfb, gst-plugins-bad,
gst-plugins-base, gst-plugins-good, gst-plugins-ugly,
perl-digest-md5, perl-mime-base64, perl-net-ping,
python-scapy3k, wireguard
Issues resolved (http://bugs.uclibc.org):
#11906: the new version of mesa3d cannot support etnaviv when..
#11996: opencv3 SIGILL on Cortex-A5 with VFPv4-D16
#12121: PyQt5.QtSerialPort and other modules not being built
#12256: package tar is outdated (1.29 is 3 years old
#12286: Can't import gobject in python 3.8
#12376: python-scapy3k is deprecated
#12386: carriage return issue when "make menuconfig"
#12441: qt5webengine build error: asm/errno.h: No such file or..
#12446: Buildroot fails to finish installing packages
#12456: qtvirtualkeyboard: No such file or directory
#12461: libglib2 build files with deep directory structure
#12481: minicom fails when output directory path contains "m4"
#12501: libnss-3.49.1: ld error: multiple definition of `gcm_..
#12526: host-nodejs 12.14.1: configure fail: AttributeError: ..
#12536: Linux-Headers extracting failure
#12546: Ninja 1.10 build Error
2019.11.3, released April 10th, 2020
Important / security related fixes.
core: Fix compatibility with make 4.3+. Also fixup /lib
references in libtool .la files, similar to how it is done for
/usr/*.
toolchain: Fix kernel headers validation check for external
toolchains.
fs/initramfs: fix show-info so it also shows the usual
rootfs-related variables.
Updated/fixed packages: barebox-aux, bluez5_utils, busybox,
civetweb, cog, collectd, ffmpeg, gcc, gnutls, gssdp, gvfs, haproxy,
hiredis, hostapd, kmscube, libical, libopenssl, libsndfile,
linux-tools, llvm, monit, ntp, php, pure-ftpd, radvd, redis,
samba4, screen, sysdig, syslinux, syslog-ng, tor, uacme,
util-linux, vala, vlc, wpa_supplicant, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#12746: "sysdig" package description points to http://sysdig.org, ..
2019.11.2, released March 16th, 2020
Important / security related fixes.
Core: Ensure package-file-lists data is correct after
incremental builds as well.
Fix a race condition related to creating the output/staging
symlink on systems with coreutils < 8.27.
Toolchain: ARC tools bumped to arc-2019.09.
Br2-external: Fix patch handling when external linux-extension
packages are used. Fix compatibility with make 4.3+
Util-linux: Ensure that hwclock is built without GPLv3
code. Notice that builds with hwclock has contained
GPLv3-licensed code since util-linux 2.30 (Buildroot 2017.08+)
Updated/fixed packages: armadillo, at, bcm2835, binutils,
blktrace, bluez-alsa, bootstrap, brltty, busybox, cairo,
clamav, cog, cups, czmq, dnsmasq, docker-containerd, dovecot,
dovecot-pigeonhole, e2fsprogs, elf2flt, eudev, exim, exiv2,
fbgrab, gettext-tiny, glibc, go, grep, gst1-validate, guile,
imagemagick, jhead, jpeg-turbo, kvm-unit-tests, lapack,
libarchive, libcgroup, libdrm, libevent, libexif, libftdi1,
libgdiplus, libjpeg, libsigrok, libsndfile, libssh2,
libsvgtiny, libvncserver, libvorbis, libxml2, libxslt, linknx,
lxc, lz4, mariadb, mbedtls, meson, mongoose, mosquitto, musl,
ncurses, nodejs, ntfs-3g, ogre, opencv3, openjdk, openjpeg,
openrc, openswan, openvmtools, optee-test, patch, php, piglet,
postgresql, pppd, proftpd, pure-ftpd, python-django,
python-pyqt5, python-setuptools-scm-git-archive, python3,
qemu, qt5base, qt5tools, qt5virtualkeyboard, qt5webengine,
qwt, rdesktop, ruby, runc, samba4, shellinabox,
skeleton-init-openrc, smartmontools, spdlog, sqlcipher, squid,
suricata, swig, swupdate, sysklogd, taglib, thrift,
ti-cgt-pru, uclibc, util-linux, vorbis-tools, webkitgtk,
wireshark, wpebackend-fdo, wpewebkit, xen,
xserver_xorg-server, zeromq, zsh, zziplib
Issues resolved (http://bugs.uclibc.org):
#11996: opencv3 SIGILL on Cortex-A5 with VFPv4-D16
#12331: meson issue
#12456: qtvirtualkeyboard: No such file or directory
#12461: libglib2 build files with deep directory structure
#12481: minicom fails when output directory path contains "m4"
#12606: fbgrab location has changed
2019.11.1, released January 12th, 2020
Important / security related fixes.
Infrastructure: kconfig: Fix reconfigure logic, python: Ensure
correct compiler and linker flags are used for compiled code
utils/scanpypi: Remind users to update DEVELOPERS
Defconfigs: imx6-sabresd: Fix the Qt5 display names,
imx8: Drop extra copy of U-Boot DTB
Updated/fixed packages: acsccid, bitcoin, boost, busybox,
cc-tool, cmocka, cpio, cups, dante, dialog, dillo, docker-cli,
docker-containerd, docker-engine, easy-rsa, ebtables,
ecryptfs-utils, efl, ffmpeg, gdb, git, glibc, gnupg2, go,
gpsd, grpc, gst1-plugins-bad, iputils, jasper,
kf5-kcoreaddons, leveldb, libarchive, libfribi, libgit2,
libkrb5, libp11, librsvg, libssh, libtomcrypt, libuio, libv4l,
lirc-tools, log4cplus, lrzip, lvm2, mali-t76x,
matchbox-desktop, mender-grubenv, mmc-utils, mosquitto,
nodejs, ntp, openipmi, opencv3, openpowerlink, openrc, pango,
perl-sys-cpu, pimd, postgresql, pulseaudio, python-brotli,
python-coherence, python-crc16, python-django, python-dpkt,
python-gobject, python-pyasn-modules, python-pypcap,
python-pyqt5, python-subprocess32, python3, qpdf,
qt-webkit-kiosk, qt5virtualkeyboard, qt5webengine, quota,
rabbitmq-c, rauc, rpcbind, rtl8821au, runc, rygel, samba4,
sdl2, setserial, snort, spidev_test,
sunxi-mali-mainline-driver, syslog-ng, sysrepo, tcllib, tftpd,
usbmount, w_scan, wavpack, wsapi, wsapi-fcgi, wsapi-xavante,
x265, xserver_xorg-server, ytree, zip
Issues resolved (http://bugs.uclibc.org):
#12121: PyQt5.QtSerialPort and other modules not being built
#12286: Can't import gobject in python 3.8
2019.11, released December 1st, 2019
Various fixes.
Infrastructure: Make HOST_<pkg>_DL_OPTS inherit from
<pkg>_DL_OPTS by default, just like it is done for a number of
other package variables.
Add <pkg>_KEEP_PY_FILES to exclude specific python .py files
from the removal done by BR2_PACKAGE_PYTHON{,3}_PYC_ONLY for
the (rare) case where the .py files are needed at runtime
rather than .pyc.
Updated/fixed packages: am33x-cm3, bind, collectd, go, gob2,
gst1-plugins-bad, haproxy, jasper, jpeg-turbo, libdrm,
libftdi, libftdi1, libnss, libselinux, libstrophe, lzma,
minicom, network-manager, nodejs, oniguruma, opencv3,
openvmtools, perl-gdgraph, perl-gdtextutil, prosody,
python-cchardet, systemd, tiff, wolfssl,
Issues resolved (http://bugs.uclibc.org):
#11416: check-uniq-files staging issue
#12146: Oprofile runtime issue
#12166: Compiling nodejs for SAMA5D3 always crash with illegal inst..
#12171: Python-opencv needs config.py and config-3.7.py to run..
#12196: duma package
#12211: host-nodejs 10.15.3 package fail to build
#12316: tzdata fails to install with empty "default local time"
#12326: network-manager build fails with missing glib error
#12366: Gstreamer1 gst1-plugins-bad do not compile with RPI-Userland
2019.11-rc3, released November 24th, 2019
Fixes all over the tree.
Updated/fixed packages: asterisk, clamav, domoticz, faifa,
gerbera, kmod, kvm-unit-tests, libupnp18, linux-serial-test,
lsof, ltp-testsuite, lxc, mesa3d, mesa3d-headers, perl, php,
postgresql, qemu, rauc, redis, rpcbind, spice, spice-protocol,
systemd, tftpd, waylandpp, webkitgtk, zip
2019.11-rc2, released November 16th, 2019
Fixes all over the tree.
Toolchain: ARC tools bumped to arc-2019.09-rc1, ensure
external toolchain kernel headers version check correctly stop
the build on mismatch
Meson: Fix generation of global cross-compilation.conf
Download: Also use the package download method for extra
downloads from the same site, so it does not get confused by
URLs containing '+'
Defconfigs: Fix boot issue for beaglebone
Updated/fixed packages: bird, chrony, connman, dhcp, domoticz,
dropwatch, dtc, elf2flt, gettext-tiny, glog, intel-microcode,
ipsec-tools, jailhouse, kodi, libfribi, libmbim, libressl,
libsigrokdecode, libsvgtiny, linux-serial-test, ltp-testsuite,
lvm2, lxc, mariadb, mesa3d, minizip, ndisc6, neardal, ninja,
ofono, openvmtools, oracle-mysql, qt5wayland, safeclib, socat,
sudo, systemd, wpewebkit, xserver_xorg-server
2019.11-rc1, released November 5th, 2019
Fixes all over the tree and new features.
Dependencies: Gcc/g++ 4.8 or newer is now required on the
build host.
Ensure host has JSON::PP perl module installed if
webkitgtk/wpewebkit packages are enabled as it is needed
during their build process.
Toolchain: Add support for the D programming language (GCC
9.x, Glibc).
GCC 9.x updated to 9.2.0, Glibc updated to 2.30, Musl updated
to 1.1.24, uClibc-ng updated to 1.0.32, ARC toolchain updated
to arc-2019.09-eng002.
Musl: Add a patch to add support for
sched_{get,set}scheduler() and sched_{get,set}param() for
compatibility.
Generate check-headers program under BUILD_DIR rather than
/tmp to fix issues with distributions mounting /tmp noexec.
Also copy libssp.so for external toolchains if SSP
to handle toolchains providing SSP support in libssp rather
than in the C library
New defconfigs: Beaglebone AI, FriendlyARM Nanopi NEO Plus2,
Libre Computer "La Frite", QEMU Armv7-A with trustzone/OP-TEE,
STM32MP157 Discovery Kit
Arch: RISC-V: Default to a sensible floating point ABI based
on the selected ISA extensions rather than always defaulting
to ILP32/64
Graph-size: Package sizes are now shown in human readable form
(Kib/Mib/Gib) rather than always in Kib. Binary (KB/MB/GB)
format can be selected using the --binary option. The cut-off
limit for classifying packages as "other" is now configurable
using the --size-limit option.
Br2-external: Linux kernel extensions can now also be provided
in an external tree by adding packages under
linux/linux-ext-*.mk. See the manual for details.
Fakeroot now works correctly under Microsoft Windows 10
Services for Linux, which does not provide SYSV IPC support
The check-uniq-files logic which would complain if multiple
packages would touch the same files has been removed as it
causes issues in certain situations (when packages are
rebuilt) and the issue is no longer considered a problem for
toplevel parallel builds as those will use a per-package
staging/target directory.
With this removed, Python is no longer required for a basic
build (only for optional scripts).
support/scripts/genimage.sh will no longer make a copy of
TARGET_DIR, speeding up post-build/image scripts.
The runtime test logic now uses Python 3.x.
A 'v' prefix has been dropped from the <pkg>_SOURCE variable
for a number of packages to match the version numbers used by
https://release-monitoring.org
New packages: caps, collectl, dav1d, fstrcmp, ima-evm-utils,
jitterentropy-library, kodi-vfs-rar, kodi-vfs-sftp, libavl,
libhttpserver, libmspack, libnetconf2, libolm, libyang,
linux-serial-test, lrzip, mdevd, minimodem, musl-fts, netifrc,
ogre, openlayers, python-aioredis, python-asgiref,
python-backports-functools-lru-cache, python-bluezero,
python-brotli, python-channels, python-channels-redis,
python-colorlog, python-daphne, python-django-enumfields,
python-jaraco-functools, python-kiwisolver, python-msgfy,
python-rpi-ws281x, python-setuptools-scm-git-archive,
python-simplelogging, python-soupsieve, python-sqliteschema,
python-sqlparse, python-tqdm, python-webencodings, qt5webview,
restclient-cpp, ripgrep, snmpclitools, sunwait, sysrepo,
uacme, utf8proc, uvw, ytree
Removed packages: alljoyn, alljoyn-base, alljoyn-tcl-base,
devmem2, eventlog, kodi-audiodecoder-opus,
kodi-screensaver-planestate, kodi-visualisation-waveforhue,
python-pysnmp-apps, riscv-pk, ustr
Issues resolved (http://bugs.uclibc.org):
#9881: systemd-resolved not setting resolv.conf link
#10171: devmem2 w (word) is 8 bytes in x86 64 systems
#10586: musl gcc has ifunc enabled when musl doesn't support it
#10806: Allow nfs-utils to use ipv6
#11366: [2018.08] SysV IPC not available for fakeroot on WSL
#11411: check-uniq-files target issue
#11766: Console (getty) issues with systemd
#11781: mariadb build error
#12031: Build of cups-filters fails while linking, apparently due..
#12116: console prompt does not appear after login
#12141: eudev package is missing "render" and "kvm" groups
#12181: dropbear: norootlogin (-w) no longer works when PAM is enabled
#12186: Raspberry Pi Zero-W build fails on newer kernel versions
#12191: cmake BUILDDIR
#12241: Permission denied while running "make"
#12261: sudo versions prior to 1.8.28 are affected.
#12276: make clean/distclean does not remove BR2_DL_DIR and BR2_HOST_DIR
#12281: Custom configuration fails to build (based on raspberrypi3_..
2019.08.3, released December 7th, 2019
Important / security related fixes.
Infrastructure: Make HOST_<pkg>_DL_OPTS inherit from
<pkg>_DL_OPTS by default, just like it is done for a number of
other package variables
Add <pkg>_KEEP_PY_FILES to exclude specific python .py files
from the removal done by BR2_PACKAGE_PYTHON{,3}_PYC_ONLY for
the (rare) case where the .py files are needed at runtime
rather than .pyc.
Fix <pkg>-reconfigure handling for packages using the kconfig
infrastructure.
Toolchain: ensure external toolchain kernel headers version
check correctly stop the build on mismatch
Deconfigs: beaglebone: fix boot issue
Updated/fixed packages: am33x-cm3, asterisk, bind, chrony,
clamav, cmocka, collectd, connman, dhcp, dropwatch, faifa,
gettext-tiny, gob2, haproxy, intel-microcode, ipsec-tools,
jailhouse, jasper, jpeg-turbo, kodi, kvm-unit-tests, libftdi,
libftdi1, libnss, libressl, libstrophe, libsvgtiny, lvm2,
lzma, mariadb, minicom, mosquitto, neardal, ninja, nodejs,
oniguruma, openvmtools, oracle-mysql, perl-gdgraph,
perl-gdtextutil, php, postgresql, prosody, python-cchardet,
python-django, qt5wayland, rabbitmq, rauc, redis, rpcbind,
socat, spice, spice-protocol, tftpd, tiff, webkitgtk
New packages: libmspack
Issues resolved (http://bugs.uclibc.org):
#12166: Compiling nodejs for SAMA5D3 always crash with illegal inst..
#12171: Python-opencv needs config.py and config-3.7.py to run..
#12211: host-nodejs 10.15.3 package fail to build
#12316: tzdata fails to install with empty "default local time"
2019.08.2, released November 9th, 2019
Important / security related fixes.
Toolchain: Also copy libssp.so for external toolchains if SSP
to handle toolchains providing SSP support in libssp rather
than in the C library
Download: Also use the package download method for extra
downloads from the same site, so it does not get confused by
URLs containing '+'
Fakeroot now works correctly under Microsoft Windows 10
Services for Linux, which does not provide SYSV IPC support
utils/test-pkg: ensure to exit with an error upon failure
Updated/fixed packages: asterisk, azmq, binutils,
cups-filters, domoticz, dtc, duma, elf2flt, eudev, exfat,
exfat-utils, fakeroot, fdk-aac, file, freerdp, gcc, gd,
ghostscript, go, gpsd, grpc, gst1-plugins-base, gvfs, icu,
intel-microcode, kvm-unit-tests, libfribidi, libnspr, libnss,
libopenssl, libpcap, libpciaccess, librsvg, libseccomp,
libsigrok, libtorrent, libunwind, libva, linux-tools,
lua-sdl2, lxc, minizip, mjpegtools, mongoose, mono, nbd,
nfs-utils, php, piglit, python, python-autobahn,
python-pysnmp-apps, python-tornado, python3, qemu, qt5base,
ruby, safeclib, samba4, sdl_mixer, sox, sudo, suricata,
systemd, tcpdump, unscd, util-linux, vdr-plugin-vnsiserver,
vtun, wireshark, xvisor, yaffs2utils
Issues resolved (http://bugs.uclibc.org):
#11366: [2018.08] SysV IPC not available for fakeroot on WSL
#12261: sudo versions prior to 1.8.28 are affected
2019.08.1, released October 3rd, 2019
Important / security related fixes.
Defconfigs: AArch64-efi: Fix grub configuration, Beaglebone:
Use default console settings
Dependencies: Ensure host has JSON::PP perl module installed
if webkitgtk/wpewebkit packages are enabled as it is needed
during their build process.
Toolchain: Generate check-headers program under BUILD_DIR
rather than /tmp to fix issues with distributions mounting
/tmp noexec.
Updated/fixed packages: asterisk, augeas, axel, bind, bwm-ng,
cups, cups-filters, docker-cli, docker-engine, docker-proxy,
e2fsprogs, eudev, exim, expat, gcc, go, haveged, ifplugd, joe,
kf5-extra-cmake-modules, kf5-modemmanager-qt,
kf5-networkmanager-qt, libcamera, libcurl, libgcrypt,
libglib2, libgpg-error, libnspr, libnss, libopenssl,
logrotate, luksmeta, mariadb, mbedtls, mongodb, mosquitto,
ncurses, nfs-utils, nghttp2, nodejs, openvmtools, php,
protobuf, putty, qemu, samba4, snort, swupdate,
systemd-bootchart, thttpd, uclibc, unzip, util-linux,
wireshark
Issues resolved (http://bugs.uclibc.org):
#10806: Allow nfs-utils to use ipv6
#11781: mariadb build error
#12031: Build of cups-filters fails while linking, apparently due..
#12141: eudev package is missing "render" and "kvm" groups
#12241: Permission denied while running "make"
2019.08, released September 1st, 2019
Various fixes.
Defconfigs: Removed nanopc t4, nanopi m4 and neo4, pine64
rockpro64 and raxda rock pi4 as they rely on a ARM32 toolchain
on the build host to build ATF. These defconfigs will be added
back once a package providing such toolchain is
available. Also dropped ts4800 defconfig as it does not build
with GCC >= 8.x.
Updated/fixed packages: libxcb, php, python-numpy, webkitgtk,
wpewebkit, xfont_font-util
Issues resolved (http://bugs.uclibc.org):
#12156: buildroot-2019.08-rc3 does not build for Pi Zero W
2019.08-rc3, released August 28th, 2019
Fixes all over the tree.
Updated/fixed packages: clamav, dovecot, dovecot-pigeonhole,
gcc, intel-microcode, libmicrohttpd, libmodplug, mpg123,
nginx, openldap, python, qemu, samba4, squid, strace, vlc
Issues resolved (http://bugs.uclibc.org):
#11686: fbdev_drv.so: undefined symbol: shadowUpdatePackedWeak,..
2019.08-rc2, released August 20th, 2019
Fixes all over the tree.
Compile fixes for a number of defconfigs.
Updated/fixed packages: apache, autofs, batctl, batman-adv,
bind, collectd, cwiid, dahdi-linux, dahdi-tools, daq,
dehydrated, dhcp, dtc, efl, enlightenment, evtest, giflib,
gnutls, go, gst-plugins-bad, gst-plugins-base,
gst1-plugins-bad, gst1-plugins-base, gst1-rtsp-server, gtkmm3,
gupnp, harfbuzz, imagemagick, lftp, libbsd, libcpprestsdk,
libdnet, libfm, libgit2, libgtk2, libgtk3, libpri, librsvg,
libss7, libssh2, libwpe, lua-cqueues, metacity, micropython,
mpd, mpg123, musl, mpv, openblas, openbox, opencv, pango,
pcmanfm, piglit, pigpio, pinentry, postgresql, qemu, qt5base,
qt5enginio, qt5multimedia, qt5serialbus, quagga, quazip,
rrdtool, rygel, samba4, stellarium, tcpreplay, ti-gfx, vte,
wampcc, wilink-bt-firmware, wireless-regdb, wpebackend-fdo,
xscreensaver
Removed packages: libamcodec, odroid-mali, odroid-scripts
Issues resolved (http://bugs.uclibc.org):
#9481: NetworkManager/Ping unable to resolve domains
#10566: php.mk is missing option --with-pgsql
#10861: Package batman_adv Makefile is missing include header direct..
#11641: linux kernel .config timestamp always out of date fixed with..
#11671: russian locale ru_RU:145: LC_TIME: syntax error
#11701: recuuring of usr and in bin shortcuts are created
#11741: pigpio does not build host-pigpio
#11876: automount using host mount/umount
#11881: Build breaks with lftp package enabled and libexpat1-dev inst..
#11921: dahdi fails to build
#11936: libcpprestsdk should install to staging
#11946: wilink-bt-firmware: moved from github to http://git.ti.com/ti-bt
#11961: libpri build failure
#12086: dhcp shared libraries not installed to target
#12096: tcpreplay: build fails if libdumbnet-dev is installed in the..
#12106: daq: build fails if libdumbnet-dev is installed in the host
#12126: vc4 has neon as hard dependency
2019.08-rc1, released August 9th, 2019
Fixes all over the tree and new features.
toolchain: ARC toolchain updated to 2019.03 (binutils 2.32.51
/ GCC 8.3.1 / glibc 2.29), ARM AAarch64/ARM toolchains updated
to 2019.03. Add GCC 9.1.0, remove GCC 4.9 and 6.5, add GDB
8.3, remove GDB 7.12 and 8.0.1, default to GDB 8.2, GCC
8.3.0. Musl updated to 1.1.23, bringing support for RISC-V 64.
Architectures: Internal toolchain support for C-SKY, support
for ARC HS48 v3.1 and HS38 with Quad MAC & FPU, support for
ARM A76, A76/A55 big.LITTLE, emag, neoverse-N1, phecda and
tsv110.
Filesystems: Pass extra pax options to tar for binary
reproducibility. Build host-cpio for the --reproducible option
support when BR2_REPRODUCIBLE is enabled. Genimage updated to
version 11, bringing GPT support.
Br2-external: Add support for injecting additional options to
the list of preconfigured external toolchains and libjpeg and
openssl providers using files under provides/. See the manual
for details.
Ensure custom <pkg>_OVERRIDE_SRCDIR_RSYNC_EXCLUSIONS are
passed before the standard exclusions so they are not ignored
by rsync when using override-srcdir.
Gnuconfig updated to 2019-05-28, adding C-SKY support.
test-pkg: Correct long option handling and clean output dir
after a successful build to save disk space.
support/testing: Emulate a machine with 256MB RAM to fix
issues with certain tests running out of memory, use
virtio-rng to provide needed entrophy.
pkg-stats: support outputting in JSON format with --json for
easier post processing. The classic HTML output is still
available with --html. Parallelize access to
release-monitoring.org to speed up runtime.
Drop non-conventional version prefix/suffix/separators for
packages for better compatibility with release-monitoring.org
Packages:
Init systems: Add basic openrc support and
<pkg>_INSTALL_INIT_OPENRC variable in the infrastructure to
install openrc service scripts if enabled.
busybox: Build each applet as a separate binary when SELinux
is enabled for more finegrained policy control. Use daemon
mode for mdev rather than legacy hotplug.
linux: Workaround -Werror related build failure on powerpc,
by forcing CONFIG_PPC_DISABLE_WERROR on.
Defconfigs: QEMU: use 'rootwait' kernel option to ensure root
partition is available before mounting.
New defconfigs: HiFive Unleashed, I.MX8MM EVK and Pico, Nanopi
m4 and neo4, Nanopc t4, Olimex A33 olinuxino, Pine64
Rockpro64, PowerPC mac99, QEMU C-SKY 610/807/810/860 virt,
Raspberry Pi 4, Raxda rock pi4, Solidrun Clearfog GT-8K
Removed defconfigs: Odroid C2
New packages: bitcoin, c-capnproto, fatcat, ifmetric, jack1,
jailhouse, libubootenv, luasyslog, mender-grubenv,
murata-cyw-fw, openrc, piglit, python-colorama, python-cycler,
python-hiredis, python-ifaddr, python-inflection,
python-iptables, python-matplotlib, python-periphery,
python-pycairo, python-redis, python-termcolor,
python-tinyrpc, python-txdbus, skeleton-init-openrc, spdlog,
sshguard, stellarium, zziplib
Removed packages: xapp_mkfontdir
Issues resolved (http://bugs.uclibc.org):
#11096: Upgrade from glibc 2.26 to 2.27 broke some locales...
#11271: utils/check-package fails with exception depending on..
#11991: [numpy] segfault when compiling for RPi3 64bits
#12016: Grub fails to boot bzImage after upgrade to 2019.05
#12046: Can’t login as root user after upgrading to buildroot..
#12051: package/dhcp installs libtool wrapper scripts on tar...
#12076: Patchelf can link against an incompatible libc++ ver...
2019.05.3, Released October 3rd, 2019
Important / security related fixes.
Defconfigs: AArch64-efi: Fix grub configuration, Beaglebone:
Use default console settings
Dependencies: Ensure host has JSON::PP perl module installed
if webkitgtk/wpewebkit packages are enabled as it is needed
during their build process.
Toolchain: Generate check-headers program under BUILD_DIR
rather than /tmp to fix issues with distributions mounting
/tmp noexec.
Updated/fixed packages: asterisk, augeas, bind, bwm-ng, cups,
cups-filters, docker-cli, docker-engine, docker-proxy,
e2fsprogs, eudev, exim, expat, gcc, go, haveged, ifplugd,
iptables, joe, kf5-extra-cmake-modules, kf5-modemmanager-qt,
kf5-networkmanager-qtlibcamera, libcurl, libgcrypt,
libgpg-error, libnftl, libnspr, libnss, libopenssl,
libtorrent-rasterbar, luksmeta, mariadb, mbedtls, mongodb,
mosquitto, ncurses, nfs-utils, nghttp2, nodejs, openvmtools,
php, protobuf, putty, qemu, samba4, swupdate,
systemd-bootchart, thttpd, uclibc, unzip, util-linux,
wireshark
Issues resolved (http://bugs.uclibc.org):
#10806: Allow nfs-utils to use ipv6
#11781: mariadb build error
#12031: Build of cups-filters fails while linking, apparently due..
#12141: eudev package is missing "render" and "kvm" groups
#12241: Permission denied while running "make"
2019.05.2, Released September 3rd, 2019
Important / security related fixes.
Filesystems: Pass extra pax options to tar for binary
reproducibility.
Updated/fixed packages: apache, arm-trusted-firmware,
asterisk, atk, autofs, batctl, batman-adv, berkeleydb,
busybox, bzip2, clamav, cloop, cmake, collectd, connman-gtk,
dahdi-linux, dahdi-tools, daq, dehydrated, dhcp, dovecot,
dovecot-pigeonhole,, elfutils, evtest, exim, expect, giflib,
git, glib-networking, glibc, gnupg2, gnutls, go,
gst1-rtsp-server, gtkperf, gupnp-tools, gvfs, imagemagick,
imx-uuc, intel-microcode, json-glib, lftp, libbsd, libcurl,
libgit2, libgtk2, libgtk3, libmodplug, libnss, libpri,
libshout, libss7, libssh2, libvips, libxcb, linux-headers,
mdadm, mesa3d, metacity, mpg123, mosquitto, musl, nginx,
oniguruma, openblas, opencv3, openjdk, openjdk-bin, openldap,
openvmtools, pcmanfm, php, pigpio, postgresql, prboom,
proftpd, proj, python, python-django, python-idna,
python-numpy, python-urllib3, python3, qemu, qt5, qt5base,
qt5enginio, quagga, rygel, squid, subversion, tcpreplay,
unzip, vlc, vte, webkitgtk, wireless-regdb, xen,
xfont_font-util, xlib_libICE, xlib_libXfont, xlib_libXfont2,
yad, zeromq
Issues resolved (http://bugs.uclibc.org):
#11741: pigpio does not build host-pigpio
#11876: automount using host mount/umount
#11881: Build breaks with lftp package enabled and libexpat1-dev inst..
#11921: dahdi fails to build
#11961: libpri build failure
#12086: (dhcpd-missing-libs) - dhcp shared libraries not installed to..
#12096: tcpreplay: build fails if libdumbnet-dev is installed in the..
#12106: daq: build fails if libdumbnet-dev is installed in the host
#12126: vc4 has neon as hard dependency
2019.05.1, Released July 7th, 2019
Important / security related fixes.
arch: x86: Fix typo breaking 'core-avx2' variant
linux: Workaround -Werror related build failure on powerpc,
by forcing CONFIG_PPC_DISABLE_WERROR on.
support/testing: Emulate a machine with 256MB RAM to fix
issues with certain tests running out of memory.
test-pkg: Correct long option handling and clean output dir
after a successful build to save disk space.
Defconfigs: QEMU: use 'rootwait' kernel option to ensure root
partition is available before mounting.
Updated/fixed packages: barebox, busybox, bzip2, davfs2,
dialog, docker-cli, docker-engine, exim, expat, faad2,
haveged, irssi, libcamera, libcdaudio, libcurl, libglib2,
libressl, libsecret, lmbench, meson, monit, php, postgresql,
psplash, python-django, qt5base, tvheadend, webkitgtk,
xserver_xorg-server, znc
2019.05, released June 2nd, 2019
Various fixes.
Toolchain: Ensure pre-built Andes toolchains can only be
selected when x86 32bit support is available on the host.
Disallow PowerPC SPE ABI for GCC >= 8.x, as it is no longer
supported.
Infra: pkg-config: Use a dedicated timestamp file rather than
.config as that gets touched by linux-4.19+, causing repeated
builds.
Add C-SKY support to our config.sub (gnuconfig)
Updated/fixed packages: dosfstools, botan, brotli, dropbear,
flare-engine, gst1-plugins-bad, libhtp, libnss, libopenssl,
linuxptp, matchbox-panel, mender, mutt, netsurf,
network-manager, opencv3, openjdk, openmpi, php,
python-cython, qt5multimedia, qtwayland, qt5webkit-examples,
supertux, suricata, tpm2-totp, v4l2loopback, wireshark,
wpewebkit
2019.05-rc3, released May 25th, 2019
Fixes all over the tree.
check-bin-arch: Ignore /usr/lib/grub, similar to how /lib/grub
is ignored.
check-package: Warn about utf-8 characters in .mk files
Linux: Default to 5.1.x series
Updated/fixed packages: assimp, atop, chocolate-doom, cjson,
ddrescue, dhcp, ffmpeg, gerbera, glibmm, gpsd, gst-ffmpeg,
intel-microcode, jasper, keepalived, kismet, libcpprestsdk,
libcurl, libssh2, libupnp18, luarocks, mono-gtksharp3, opus,
postgresql, pcsc-lite, python, tslib, webkitgtk,
wpebackend-fdo, wpewebkit
2019.05-rc2, released May 15th, 2019
Fixes all over the tree.
Updated/fixed packages: bind, bullet, ca-certificates,
collectd, cracklib, dhcp, gdb, libinput, libtorrent-rasterbar,
linknx, lynx, mono, netsurf, optee-os, postgresql, qt5enginio,
qt5multimedia, rpm, samba4, sqlite, strace, uclibc, woff2
Issues resolved (http://bugs.uclibc.org):
#11841: grub-efi.cfg not used when building EFI disk image
2019.05-rc1, Released May 8th, 2019
Fixes all over the tree and new features.
Architecture: Andes 32-bit (nds32) support added.
Only build host-lzip / host-xz when really needed by packages,
not just when not available on the build host.
Toolchain: Glibc bumped to 2.29, musl bumped to 1.1.22,
binutils 2.32 added, 2.28/2.29 removed, default changed to
2.31.1.
fs: Set FAKEROOTDONTTRYCHOWN environment variable to not
forward {f,l,}chown calls to libc when running under fakeroot
to fix issues when building in restricted environments
(E.G. user namespace with bubblewrap).
Linux: Also build default make target to ensure extra files
like the gdb scripts enabled by CONFIG_GDB_SCRIPTS are also
built. Notice: This may mean that extra host utilities like
uboot-mkimage are needed.
Infrastructure: show-info and <pkg>-show-info make targets
added to output package metadata in JSON format for external
use.
pkg-generic: Only tweak .la files needing it to ensure they
are not included in subsequent package file lists.
test-pkg: Generate a basic package config if none is
specified.
Gettext-tiny package added as an lightweight replacement for
GNU gettext for situations where NLS support is not needed.
New defconfigs: Andes AE3XX, Freescale imx8mpico / imx8qxpmek
/ T2080 QDS RDB, Licheepi zero, Orangepi R1
Removed defconfigs: Olimx A20 Olinuxino Lime legacy
New packages: bats-core, bayer2rgb-neon, brickd, cog, dacapo,
enet, gettext-tiny, gli, gst1-plugins-bayer2rgb-neon,
imx-sc-firmware, intel-mediadriver, intel-mediasdk, libcamera,
libhtp, libp11, libwpe, lua-binaryheap, lua-gd, lua-lunitx,
mender-artifact, most, oniguruma, openjdk, openjdk-bin,
opensbi, optee-benchmark, optee-client, optee-examples,
optee-os, optee-test, paho-mqtt-cpp, python-aioblescan,
python-aioconsole, python-aiohttp-cors, python-aiomonitor,
python-backcall, python-jedi, python-parso, python-pyjwt,
python-terminaltables, suricata, tpm2-totp, uftp,
wpebackend-fdo, wpewebkit
Removed packages: libump, lunit, sunxi-mali
Issues resolved (http://bugs.uclibc.org):
#11716: Typo on website, saying latest release is 2018.2.11
#11756: package/syslinux: MBR's don't fit because of binutils..
#11761: Building custom kernel 5.1-rc3 or later breaks on objtool
#11816: Only selected coreutils binaries are installed
2019.02.11, released April 9th, 2020
Important / security related fixes.
core: Fix compatibility with make 4.3+. Also fixup /lib
references in libtool .la files, similar to how it is done for
/usr/*.
toolchain: Fix kernel headers validation check for external
toolchains.
Updated/fixed packages: barebox-aux, bluez5_utils, busybox,
civetweb, collectd, ffmpeg, gcc, gnutls, gvfs, haproxy,
hiredis, kmscube, libical, libopenssl, libsndfile,
linux-tools, ntp, php, pure-ftpd, screen, sysdig, tor,
util-linux, vala, vlc, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#12746: "sysdig" package description points to http://sysdig.org, ..
2019.02.10, released March 16th, 2020
Important / security related fixes.
Core: Ensure package-file-lists data is correct after
incremental builds as well.
Fix a race condition related to creating the output/staging
symlink on systems with coreutils < 8.27.
Br2-external: Fix compatibility with make 4.3+
Util-linux: Ensure that hwclock is built without GPLv3
code. Notice that builds with hwclock has contained
GPLv3-licensed code since util-linux 2.30 (Buildroot 2017.08+)
Updated/fixed packages: armadillo, at, binutils, blktrace,
bootstrap, busybox, cairo, cups, czmq, dnsmasq,
docker-containerd, dovecot, dovecot-pigeonhole, e2fsprogs,
eudev, exim, exiv2, fbgrab, grep, gst1-validate, guile,
imagemagick, jhead, kvm-unit-tests, lapack, libcgroup,
libftdi1, libjpeg, libsigrok, libsndfile, libssh2, libsvgtiny,
libvncserver, libvorbis, libxml2, libxslt, linux, lz4,
mariadb, mbedtls, meson, mfgtools, mongoose, ncurses, ntfs-3g,
opencv3, openjpeg, openswan, openvmtools, patch, php,
postgresql, pppd, proftpd, pure-ftpd, python-django,
python-pyqt5, python3, qemu, qt5base, qt5webengine, qwt,
rdesktop, ruby, runc, samba4, shellinabox, smartmontools,
sqlcipher, squid, swupdate, sysklogd, taglib, thrift,
ti-cgt-pru, uboot, util-linux, vorbis-tools, webkitgtk,
wireshark, xen, xserver_xorg-server, zeromq, zsh
Issues resolved (http://bugs.uclibc.org):
#11996: opencv3 SIGILL on Cortex-A5 with VFPv4-D16
#12331: meson issue
#12461: libglib2 build files with deep directory structure
#12606: fbgrab location has changed
2019.02.9, released January 12th, 2020
Important / security related fixes.
pkg-python infrastructure: Ensure correct compiler and linker
flags are used for compiled code
utils/scanpypi: Remind users to update DEVELOPERS
Updated/fixed packages: busybox, cc-tool, cpio, cups, dante,
dillo, docker-cli, docker-containerd, docker-engine, easy-rsa,
ecryptfs-utils, efl, git, glibc, gnupg2, gst1-plugins-bad,
kf5-kcoreaddons, libarchive, libgit2, libkrb5, librsvg,
libssh, libtomcrypt, libuio, lirc-tools, lvm2,
matchbox-desktop, nodejs, ntp, opencv3, openpowerlink,
python-django, python-ecdsa, python-pyasn-modules,
python-pyqt5, python-subprocess32, python3, qpdf, runc, rygel,
samba4, sdl2, wavpack, xserver_xorg-server, zip
Issues resolved (http://bugs.uclibc.org):
#12121: PyQt5.QtSerialPort and other modules not being built
2019.02.8, released December 7th, 2019
Important / security related fixes.
Infrastructure: Make HOST_<pkg>_DL_OPTS inherit from
<pkg>_DL_OPTS by default, just like it is done for a number of
other package variables
Add <pkg>_KEEP_PY_FILES to exclude specific python .py files
from the removal done by BR2_PACKAGE_PYTHON{,3}_PYC_ONLY for
the (rare) case where the .py files are needed at runtime
rather than .pyc.
Fix <pkg>-reconfigure handling for packages using the kconfig
infrastructure.
Toolchain: ensure external toolchain kernel headers version
check correctly stop the build on mismatch
Deconfigs: beaglebone: fix boot issue
Updated/fixed packages: am33x-cm3, asterisk, bind, chrony,
clamav, collectd, connman, faifa, gob2, haproxy,
intel-microcode, ipsec-tools, jasper, jpeg-turbo, kodi,
kvm-unit-tests, libftdi, libftdi1, libnss, libstrophe,
libsvgtiny, lvm2, lzma, mariadb, minicom, neardal, nodejs,
opencv3, openvmtools, oracle-mysql, perl-gdgraph,
perl-gdtextutil, php, postgresql, prosody, python-django,
rabbitmq-c, rauc, redis, rpcbind, socat, spice,
spice-protocol, tftpd, tiff, webkitgtk
New packages: libmspack
Issues resolved (http://bugs.uclibc.org):
#12166: Compiling nodejs for SAMA5D3 always crash with illegal inst..
#12171: Python-opencv needs config.py and config-3.7.py to run..
#12211: host-nodejs 10.15.3 package fail to build
#12316: tzdata fails to install with empty "default local time"
2019.02.7, Released November 10th, 2019
Important / security related fixes.
support/testing: use a kernel with HW_RANDOM_VIRTIO to work
around issues with lack of entrophy
Toolchain: Also copy libssp.so for external toolchains if SSP
is enabled to handle toolchains providing SSP support in
libssp rather than in the C library
Download: Also use the package download method for extra
downloads from the same site, so it does not get confused by
URLs containing '+'
Fakeroot now works correctly under Microsoft Windows 10
Services for Linux, which does not provide SYSV IPC support
utils/test-pkg: ensure to exit with an error upon failure
Updated/fixed packages: asterisk, azmq, cups-filters,
domoticz, duma, elf2flt, eudev, exfat, exfat-utils, fakeroot,
file, freerdp, gd, ghostscript, go, gvfs, intel-microcode,
kvm-unit-tests, libarchive, libnspr, libnss, libopenssl,
libpcap, libpciaccess, librsvg, libseccomp, libsigrok,
libtorrent, libunwind, linux-tools, lua-sdl2, lxc, minizip,
mjpegtools, mongoose, php, python, python-pysnmp-apps,
python3, qemu, qt5base, ruby, safeclib, samba4, sdl_mixer,
sox, sudo, systemd, tcpdump, unscd, util-lkinux, vtun, xvisor,
yaffs2utils
Issues resolved (http://bugs.uclibc.org):
#11366: [2018.08] SysV IPC not available for fakeroot on WSL
#12261: sudo versions prior to 1.8.28 are affected
2019.02.6, Released October 3rd, 2019
Important / security related fixes.
Defconfigs: AArch64-efi: Fix grub configuration, Beaglebone:
Use default console settings
Dependencies: Ensure host has JSON::PP perl module installed
if webkitgtk/wpewebkit packages are enabled as it is needed
during their build process.
Toolchain: Generate check-headers program under BUILD_DIR
rather than /tmp to fix issues with distributions mounting
/tmp noexec.
Updated/fixed packages: asterisk, augeas, bind, bwm-ng, cups,
cups-filters, docker-cli, docker-engine, docker-proxy,
dropbear, e2fsprogs, eudev, exim, expat, gcc, go, ifplugd,
haveged, iptables, joe, kf5-extra-cmake-modules,
kf5-modemmanager-qt, kf5-networkmanager-qt, libcurl,
libgcrypt, libgpg-error, libnftl, libnspr, libnss, libopenssl,
luksmeta, mariadb, mbedtls, mongodb, mosquitto, ncurses,
nfs-utils, nghttp2, nodejs, openvmtools, php, protobuf, putty,
qemu, qt5base, samba4, swupdate, systemd-bootchart, thttpd,
uclibc, unzip, util-linux, wireshark
Issues resolved (http://bugs.uclibc.org):
#10806: Allow nfs-utils to use ipv6
#11781: mariadb build error
#12031: Build of cups-filters fails while linking, apparently due..
#12141: eudev package is missing "render" and "kvm" groups
#12181: dropbear: norootlogin (-w) no longer works when PAM is enabled
#12241: Permission denied while running "make"
2019.02.5, Released September 2nd, 2019
Important / security related fixes.
Filesystems: Pass extra pax options to tar for binary
reproducibility.
Updated/fixed packages: apache, arm-trusted-firmware,
asterisk, atk, autofs, batctl, batman-adv, berkeleydb, brotli,
busybox, bzip2, clamav, cloop, cmake, collectd, connman-gtk,
cryptopp, dahdi-linux, dahdi-tools, daq, dehydrated, dovecot,
dovecot-pigeonhole,, elfutils, evtest, exim, expect, giflib,
git, glib-networking, glibc, gnupg2, gnutls, go,
gst1-rtsp-server, gtkperf, gupnp-tools, gvfs, imagemagick,
imx-uuc, intel-microcode, json-glib, lftp, libbsd, libcurl,
libgit2, libgtk3, libmodplug, libnss, libpri, libshout,
libss7, libssh2, libvips, libxcb, linux-headers, mdadm,
mesa3d, metacity, mpg123, mosquitto, musl, nginx, openblas,
opencv3, openldap, openvmtools, pcmanfm, php, pigpio,
postgresql, prboom, proftpd, proj, python, python-django,
python-idna, python-numpy, python-urllib3, python3, qemu, qt5,
qt5base, qt5enginio, quagga, rygel, squid, subversion,
tcpreplay, unzip, vlc, vte, webkitgtk, weston, wireless-regdb,
xen, xfont_font-util, xlib_libICE, xlib_libXfont,
xlib_libXfont2, yad, zeromq
Issues resolved (http://bugs.uclibc.org):
#11741: pigpio does not build host-pigpio
#11876: automount using host mount/umount
#11881: Build breaks with lftp package enabled and libexpat1-dev inst..
#11921: dahdi fails to build
#11961: libpri build failure
#12096: tcpreplay: build fails if libdumbnet-dev is installed in the..
#12106: daq: build fails if libdumbnet-dev is installed in the host
#12126: vc4 has neon as hard dependency
2019.02.4, Released July 10th, 2019
Important / security related fixes.
arch: x86: Fix typo breaking 'core-avx2' variant, add Westmere
variant.
linux: Workaround -Werror related build failure on powerpc,
by forcing CONFIG_PPC_DISABLE_WERROR on.
support/testing: Emulate a machine with 256MB RAM to fix
issues with certain tests running out of memory.
test-pkg: Correct long option handling and clean output dir
after a successful build to save disk space.
Ensure custom <pkg>_OVERRIDE_SRCDIR_RSYNC_EXCLUSIONS are
passed before the standard exclusions so they are not ignored
by rsync when using override-srcdir.
Defconfigs: QEMU: use 'rootwait' kernel option to ensure root
partition is available before mounting.
Updated/fixed packages: barebox, bzip2, davfs2, dbus, dialog,
docker-cli, docker-engine, expat, faad2, ffmpeg, freeswitch,
gerbera, haveged, irssi, libcdadio, libgit2, libglib2,
libsecret, libvncserver, lmbench, logrotate, mariadb, meson,
mongoose, monit, mpd, openblas, php, postgresql, psplash,
python, python-django, python3, qt5base, samba4, taglib,
tvheadend, vlc, webkitgtk, xserver_xorg-server, znc
2019.02.3, Released June 7th, 2019
Important / security related fixes.
Infra: pkg-config: Use a dedicated timestamp file rather than
.config as that gets touched by linux-4.19+, causing repeated
builds.
check-bin-arch: Also ignore /usr/lib/grub to support merged
/usr setups, similar to how /lib/grub is ignored.
gnuconfig/config.sub: Add C-SKY architecture support.
Updated/fixed packages: assimp, atftp, atop, botan, busybox,
ca-certificates, chocolate-doom, cjson, coreutils, cracklib,
ddrescue, dhcp, docker-cli, docker-containerd, docker-engine,
dosfstools, dovecot, dovecot-pigeonhole, dropbear, exim,
ffmpeg, flare-engine, gcc, gdb, gerbera, glibmm, go, gpsd,
gst-ffmpeg, gst1-plugins-bad, gst1-plugins-base, imagemagick,
intel-microcode, jasper, kf5-kcoreaddons, kismet, libcurl,
libglib2, libnss, libopenssl, libsigrok, libssh2, libupnp18,
linuxptp, luajit, lynx, matchbox-panel, mender,
netcat-openbsd, netsurf, nfs-utils, opus, orc, owfs,
pcsc-lite, php, popt, postgresql, python, python-cython,
python-django, python-ply, qt5enginio, rpm, runc, samba4,
sqlite, subversion, supertux, systemd, tslib, uclibc,
v4l2loopback, webkitgtk, woff2
Issues resolved (http://bugs.uclibc.org):
#11816: Only selected coreutils binaries are installed
#11841: grub-efi.cfg not used when building EFI disk image
#11911: systemd v240 memory leak in systemd-journald
2019.02.2, Released April 29th, 2019
Important / security related fixes.
Only build host-lzip / host-xz when really needed by packages,
not just when not available on the build host.
fs: Set FAKEROOTDONTTRYCHOWN environment variable to not
forward {f,l,}chown calls to libc when running under fakeroot
to fix issues when building in restricted environments
(E.G. user namespace with bubblewrap).
Linux: Also build default make target to ensure extra files
like the gdb scripts enabled by CONFIG_GDB_SCRIPTS are also
built. Notice: This may mean that extra host utilities like
uboot-mkimage are needed.
Defconfigs: ASUS tinker and Amarula vyasa rk3822: Support
larger kernel images, Atmel SAM5D27, SAM5D2,3,4 xplained:
Increase rootfs size to fit utilities, Raspberry Pi 64bit:
Include overlays in sdcard image
Updated/fixed packages: android-tools, apache, bind, binutils,
busybox, civetweb, cjson, copas, davfs2, docker-cli,
docker-containerd, docker-engine, dovecot, dovecot-pigeonhole,
freerdp, gerbera, ghostscript, git, gnutls, go, gst-omx,
gst1-plugins-base, gst1-plugins-ugly, haproxy, hostapd,
ipsec-tools, libfreefare, libfuse, libkrb5, libpng, libxml2,
libxslt, linknx, linux, linux-firmware, linux-tools, live555,
lldp, lrzsz, lynx, madplay, make, minicom, mongodb, msmtp,
musl, mutt, neon, netsnmp, numactl, opus, perl, php,
postgresql, pure-ftpd, python-urllib3, python3, qt5base,
rapidxml, rpm, rsyslog, ruby, runc, samba4, sane-backends,
softether, stunnel, sysklogd, syslinux, syslog-ng,
systemd-bootchart, thttpd, thrift, tiff, tor, tpm2-tools,
tpm2-tss, webkitgtk, yaffs2utils, wget, wpa_supplicant, wsapi,
xapp_xfd, xapp_xload, xlib_libXpm, xserver_xorg-server, xz,
znc
Issues resolved (http://bugs.uclibc.org):
#11756: package/syslinux: MBR's don't fit because of binutils..
#11761: Building custom kernel 5.1-rc3 or later breaks on objtool
2019.02.1, Released March 29th, 2019
Important / security related fixes.
pkg-generic: Only tweak .la files needing it to ensure they
are not included in subsequent package file lists.
test-pkg: Generate a basic package config if none is
specified.
Updated/fixed packages: asterisk, avahi, bash, beecrypt,
binutils, busybox, clamav, cups, efl, eigen, fetchmail, file,
flashrom, fltk, gerbera, git, glibc, gnuradio, go,
gst-plugins-bad, intel-gmmlib, jq, kexec, kf5-modemmanager-qt,
leveldb, libcurl, libdrm, libftdi1, libglib2, libiio, libpcap,
libseccomp, libssh2, log4cplus, lvm2, mariadb, mender,
mongodb, mosquitto, musl, nodejs, ntp, openjpeg, owfs, php,
pure-ftpd, putty, python-aiojobs, qt5webkit, rdesktop, samba4,
sunxi-tools, supertux, swupdate, tpm2-abrmd, tpm2-tss,
wavemon, wireshark, vsftpd, xapp_xdm, xen,
xdriver_xf86-video-fbdev, xlib_libXdmcp
Issues resolved (http://bugs.uclibc.org):
#11716: Typo on website, saying latest release is 2018.2.11
2019.02, released March 4th, 2019
Minor fixes.
Libressl support added for Qt 5.6 as a replacement for
openssl, as 5.6 is not compatible with openssl 1.1.x.
Updated/fixed packages: cutelyst, devmem2, gqrx,
gst-plugins-bad, libraw, libsoxr, qt5base, runc, systemd, tor
2019.02-rc3, released March 1st, 2019
Fixes all over the tree.
Openssl support dropped from Qt 5.6, as it isn't compatible
with openssl 1.1.x.
Toolchain: GCC 8.x updated to 8.3.0, fixing a number of
issues.
Dependencies: Require CMake 3.8 or newer to fix compilation
issue with certain packages. If not available, host-cmake will
instead be built.
Printvars: Fix performance regression since 2018.02
Scanypi: Correctly handle underscores in python package names.
Updated/fixed packages: botan, clamav, cryptopp, i2pd,
ibrcommon, iproute2, libcpprestsdk, libssh, lua-curl,
luaexpat, qt5base, runc, stress-ng, syslinux, systemd,
upmpdcli, zbar
Issues resolved (http://bugs.uclibc.org):
#9966: util-linux-2.30/.stamp_built' failed
#11696: possible typo in board/pc/post-build.sh
2019.02-rc2, released February 23th, 2019
Fixes all over the tree.
Removed zynq_zybo defconfig, as it hasn't seen any update
since it was added in 2016, and uses a U-Boot version not
compatible with openssl-1.1.x.
Linux: Ignore user supplied downloadable hashes, as no hash
checksums are available for those.
Updated/fixed packages: bind, cryptopp, docker-containerd,
dtc, efivar, gdb, imagemagick, ipmiutil, libcpprestsdk,
libcurl, libgpiod, libid3tag, libv4l, log4cplus, luvi,
madplay, mender, mosquitto, poco, postgresql, proftpd,
pulseaudio, python-django, qemu, qt5base, qwt, rabbitmq-c,
reaver, safeclip, stress-ng, swupdate, syslog-ng, systemd,
tor, unzip, xenomai
Issues resolved (http://bugs.uclibc.org):
#11501: compile sdl2 with enable wayland
#11681: .. unable to initialize decompress status for section..
2019.02-rc1, released February 13th, 2019
Fixes all over the tree and new features.
Dependencies:
Require Python >= 2.7 as it is needed for E.G. building
libglib2.
Ensure GNU gzip is used for reproducible tarballs (instead of
pigz)
Infrastucture:
Ensure the PLATFORM and OS environment variables are not set,
as they cause build issues for some packages.
The package list infrastructure now correctly handles packages
installing files with old mtime.
Add a config option to force all optional host utilities to be
built, even if suitable versions are available on the build
machine.
graph-build-time: Also show time spent downloading
Download: fixes for SSH/SCP support
Ensure user provided permissions override permissions from
packages.
SDK: Fix handling of relative symlinks (targets starting with
'.' or '..')
BR2_SYSTEM_DEFAULT_PATH setting to customize the default path
for processes.
The custom skeleton logic will now populate the needed /bin,
/lib, /sbin directories/symlinks if not present. Merged /usr
can now be used with a custom skeleton.
Rootfs overlays can now override symbolic links from
packages. This was disabled to ensure the correct symbolic
links are present when merged /usr is used. Instead validate
that the rootfs overlays do not include invalid /bin, /sbin
and /lib entries.
The waf infrastructure now support the <pkg>_SUBDIR variable,
similar to the other package types.
cmake: Also set CMAKE_SYSTEM_VERSION in toolchainfile.cmake
Various improvements to the meson infrastructure.
Luarocks: A Buildroot addon has been added to automate
creating a Buildroot package from luarocks, similar to
scancpan and scanpypi.
scanpypi: protect against zip-slip vulnerability in zip/tar
handling
check-package: fix Python 3 support
get-developers: Fix behaviour when called from elsewhere than
the toplevel directory.
pkg-stats: Show latest upstream version of each package, based
on data from release-monitoring.org
kconfig: Fix for make linux-menuconfig / uboot-menuconfig from
a clean tree when ccache is enabled.
Default to sha256 password encoding, drop md5 support.
Architecture:
Support for RISC-V 32bit architecture, ARM A55, 75 and Saphira
variants, MIPS support for mips32r3, mips64r3 and Marvell
Octeon II/III variants.
Toolchain:
ARC toolchain 2018.09, ARM 8.2-2018.11, Codescape IMG/MTI MIPS
2018.09-02, MUSL 1.1.21, GCC 6.5.0 / 7.4.0, GDB 8.2.1
Packages:
openssl: Bump to 1.1.1x series, bringing TLSv1.3 support and
long term support.
fftw: Split into fftw-{single,double,long-double,quad}
packages for the different data precision options.
libcurl: Now has explicit TLS backend selection options.
linux: Support building device tree blobs with the -@ option
for device tree overlays.
weston: The weston-imx i.MX variant is now used when
imx-gpu-viv is enabled
pkgconf: Update to 1.5.3, which brings support for
--define-prefix (used by GStreamer)
Add host-python3-setuptools package to handle host python
packages needing python3 with setuptools support.
New defconfigs: Aarch64 EFI, Orangepi one plus, Orangepi lite
2, QEMU RISC-V 32bit virt, Rock64
New packages: brcm-patchram-plus, clinfo, cunit, docker-cli,
erlang-p1-eimp, exempi, fail2ban, fftw-double,
fftw-double-long, fftw-quad, fftw-single, gerbera, grpc,
gst1-shark, intel-gmmlib, iwd, kf5-kcoreaddons, libeastl,
libpackagekite, libtorrent-rasterbar, lua-std-debug,
lua-std-normalize, mini-snmpd, netsurf, pamtester, pcm-tools,
python-aiodns, python-aiohttp, python-aiohttp-jinja2,
python-aiohttp-remotes, python-aiohttp-security,
python-aiohttp-session, python-aiohttpd-sse, python-aiojobs,
python-cchardet, python-pycares, python-sentry-sdk,
python-wtforms, python3-setuptools, rcw, rtc-tools, shim,
utp_com, vmtouch, websocketpp
Removed packages: fftw, lua 5.2.x, luacrypto, perl-time-hires,
python-pyqt, qt, qtuio, tn5250
Issues resolved (http://bugs.uclibc.org):
#10851: Patch to handle numpad Enter key properly
#11066: x11r7 X11 S40xorg leads to a black screen on QEMU x86..
#11126: Bash Shell Programming using Buildroot
#11426: pps-tools bash dependency
#11476: stdio2.h error invalid use of __builtin_va_arg_pack
#11536: dt-utils building fails with glibc 2.28
#11546: open-vm-tools with glibc 2.28
#11566: Fix init script
#11576: Unable to start apache with event MPM on raspberry pi 3
#11591: [pkgconf 1.5.3] xserver OpenGL support is missing
#11606: libjpeg has no Config.in
#11616: 2018.02.09 fails to build libzlib with full RELRO..
#11656: Custom device tree and u-boot boot.scr not integrated..
#11666: Touchscreen with (Py)Qt5 should use tslib instead of evdev
2018.11.4, Released March 28th, 2019
Important / security related fixes.
Updated/fixed packages: avahi, beecrypt, binutils, botan,
busybox, clamav, cups, devmem2, efl, fetchmail, file, fltk,
gcc, gdb, git, go, gst-plugins-bad, iproute2, jq,
kf5-modemmanager-qt, leveldb, libopenssl, libraw, libseccomp,
libsoxr, libssh2, mariadb, mosquitto, nodejs, ntp, openjpeg,
perl, php, putty, qt5webkit, rdesktop, runc, samba4, swupdate,
systemd, tor, vsftpd, wireshark, xapp_xdm, xen, xlib_libXdmcp
2018.11.3, Released February 23th, 2019
Important / security related fixes.
Ensure the PLATFORM and OS environment variables are not set,
as they cause build issues for some packages.
The package list infrastructure now correctly handles packages
installing files with old mtime.
Linux: Skip hash checks for user supplied downloadable
patches, as no hash checksums are available for those.
scanpypi: protect against zip-slip vulnerability in zip/tar
handling
Download: fixes for SSH/SCP support
SDK: Fix handling of relative symlinks (targets starting with
'.' or '..')
Updated/fixed packages: bind, dhcpcd, docker-compose,
docker-containerd, docker-engine, dovecot, dovecot-pigeonhole,
dtc, efivar, ghostscript, gnuradio, imagemagick, jpeg-turbo,
libarchive, libb64, libcurl, libgeotiff, libgpiod, libid3tag,
libupnp18, log4cplus, madplay, meson, mosquitto, openssh, php,
poco, postgresql, proftpd, pulseaudio, python, python-django,
python3, qt5base, reaver, runc, sg3_utils, sqlcipher,
swupdate, systemd, unzip, webkitgtk, xenomai
2018.11.2, Released January 30th, 2019
Important / security related fixes.
Defconfigs: Fixes for imx6slevk, imx7dsabresd, imx8mqevk, Lego
EV3, QEMU AArch64-virt
Download: Fix scp download handling
check-package: fix Python 3 support
get-developers: Fix behaviour when called from elsewhere than
the toplevel directory.
kconfig: Fix for make linux-menuconfig / uboot-menuconfig from
a clean tree when ccache is enabled.
cmake: Also set CMAKE_SYSTEM_VERSION in toolchainfile.cmake
Updated/fixed packages: acpica, apache, apr, avrdude, cargo,
cc-tool, dash, dhcpdump, dmalloc, docker-containerd, efivar,
fwts, glibc, gnuchess, gnupg2, go, leveldb, libarchive,
libassuan, libftdi1, libgpg-error, libhttpparser, libkcapi,
libmad, libsndfile, libsquish, liburiparser, libwebsock,
libxml2, lighttpd, llvm, lm-sensors, lua-msgpack-native, lxc,
mariadb, mbedtls, meson, mosquitto, netatalk, nodejs, odhcp6c,
openresolv, openssh, pango, patchelf, php, python-django,
python-numpy, python-pyyaml, rauc, rp-pppoe, s6-networking,
samba4, sdl_sound, shairport-sync, sqlite, subversion,
sunxi-cedarx, swupdate, systemd, tcpreplay, tekui, tmp2-abrmd,
tpm2-tools, tpm2-tss, udisks, unixodbc, usb_modeswitch,
webkitgtk, wireshark, wolfssl, xapp_rgb, xenomai, xerces
Issues resolved (http://bugs.uclibc.org):
#11576: Unable to start apache with event MPM on raspberry pi 3
2018.11.1, Released December 20th, 2018
Important / security related fixes.
defconfigs: Fixes for bananapi m2 ultra, ci20
Download wrapper: Fix for urlencode handling
Updated/fixed packages: asterisk, docker-compose,
docker-engine, dt-utils, gnutls, go, grub, libbsd, libcurl,
libpgpme, libiscsi, liblo, libmpd, libopenssl, liboping,
libpam-tacplus, libpjsip, linux-firmware, liquid-dsp,
lua-cqueue, luvi, lxc, lynx, nginx, nodejs, openzwave, php,
pps-tools, proftpd, prosody, sdl2_net, squashfs, swupdate,
uclibc, vtu, webkitgtk, wine, xen
New packages: docker-cli
Issues resolved (http://bugs.uclibc.org):
#11426: pps-tools bash dependency
#11536: dt-utils building fails with glibc 2.28
2018.11, Released December 1st, 2018
Minor fixes.
Updated/fixed packages: c-ares, quagga, squid
2018.11-rc3, released November 30th, 2018
Fixes all over the tree.
Defconfigs: Fixes for Armadeus APF27, imx6sabre, Olimex A20
olinuxino lime legacy, Orangepi zero plus 2, PC, Riotboard.
graph-depends: Fix for package names starting with a non-alpha
character.
Updated/fixed packages: alsa-utils, botan, dante, domoticz,
dtc, freetype, gauche, gcc, gdb, ghostscript, glibc,
imx-usb-loader, libbsd, libid3tag, libkrb5, libmicrohttpd,
libopenssl, libsoxr, linux, motion, msgpack, mtd,
perl-net-ssleay, php, popt, python-numpy, qt5declarative,
samba4, shadowsocks-libev, stress-ng, systemd, usb_modeswitch,
webkitgtk, valgrind, weston, xfsprogs
2018.11-rc2, released November 21th, 2018
Fixes all over the tree.
fs: Drop intermediate tarball from the filesystem handling to
fix an issue with xattrs handling related to fakeroot. Ensure
tarball target includes xattrs.
download: Fix confusion in git submodule handling if dl/ is a
symlink.
genrandconfig: Fix missing newline in BR2_WGET handling,
causing the following line to be ignored. This would affect
BR2_ENABLE_DEBUG, BR2_INIT_BUSYBOX, BR2_INIT_SYSTEMD,
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV, BR2_STATIC_LIBS or
BR2_PACKAGE_PYTHON_PY_ONLY depending on the randomization.
show-build-order: Also include the dependencies of
rootfs-common.
Fix a number of build issues in packages for the recently
merged RISC-V architecture support.
Updated/fixed packages: dt-utils, easydbus, elfutils,
flare-engine, flatcc, glibc, gstreamer, gstreamer1, imx-uuc,
libassuan, libcorrect, libiscsi, libkrb5, libmicrohttpd,
libnftnl, libnspr, libnss, libsemanage, libsigsegv, libv4l,
ltp-testsuite, luv, luvi, make, ncmpc, netplug, openocd,
prosody, qemu, rpm, sconeserver, shadowsocks-libev,
supertuxcart, syslinux, systemd, trace-cmd, uclibc,
uclibc-ng-test, vtun, webkitgtk, weston, wireshark, xen,
xlib_libfontenc
Issues resolved (http://bugs.uclibc.org):
#11086: download/git submodule breaks on symlinked dl folder
#11216: Capabilities not applied to filesystem
2018.11-rc1, released November 9th, 2018
Fixes all over the tree and new features.
Architecture: RISC-V support (64bit) added.
Toolchain: Glibc bumped to 2.28. Fortran support for external
toolchains. ARM (Linaro) toolchains updated to 8.2-2018.08.
Hardening flags (RELRO) are now handled by the toolchain
wrapper instead of explicitly through CFLAGS/LDFLAGS, fixing a
number of issues.
Filesystems: Support for creating btrfs and f2fs filesystems
added.
Add a number of patches to fix build errors for host utilities
on modern distributions using glibc-2.28.
mkusers: Ensure existing group members are preserved when a
group is reprocessed.
printvars: Fix issue with exceeding shell command line length
limits for certain setups.
Workaround added for incompatibility issues between host-dtc
and older U-Boot and Linux kernel versions.
Detect and reject build paths containing '@', as this confuses
a number of packages, including GCC.
utils/diffconfig: Make it work for (non-Buildroot) config
files not using the BR2_ prefix.
New defconfigs: Amarula a64-relic, Bananapi m2 ultra, Embest
riotboard, Hardkernel Odroid XU-4, QEMU riscv64-virt.
olimex_a20_olinuxion_lime_mali is renamed to _legacy.
OpenCL infrastructure support added, similar to how OpenGL is
handled.
Linux-headers: Support for kernel headers from a custom
tarball / git repo added.
New packages: bird, bluez5_utils-headers, btrfs-progs,
checksec, davici, duktape, ell, haproxy, libclc, libcorrect,
libopencl, libopenresolv, nss-myhostname,
perl-apache-logformat-compiler, perl-appconfig,
perl-astro-suntime, perl-class-inspector, perl-class-load,
perl-class-method-modifiers, perl-class-std,
perl-class-std-fast, perl-cookie-baker, perl-data-dump,
perl-data-optlist, perl-data-uuid, perl-data-manip,
perl-dbd-mysql, perl-dbi, perl-devel-globaldestruction,
perl-devel-stacktrace, perl-devel-stacktrace-ashtml,
perl-device-serialport, perl-dist-checkconflicts,
perl-exporter-tiny, perl-file-sharedir, perl-file-slurp,
perl-filesys-notify-simple, perl-hash-multivalue,
perl-http-entity-parser, perl-http-headers-fast,
perl-http-multipartparser, perl-io-interface,
perl-io-socket-multicast, perl-json-maybexs, perl-mime-tools,
perl-module-implementation, perl-module-runtime, perl-moo,
perl-number-bytes-human, perl-package-stash, perl-params-util,
perl-plack, perl-posix-strftime-compiler, perl-role-tiny,
perl-streams-buffered, perl-sub-exporter-progressive,
perl-sub-install, perl-sub-quote, perl-sys-cpu,
perl-sys-meminfo, perl-sys-mmap, perl-time-parsedate,
perl-type-tiny, perl-www-form-urlencoded, perl-x10, pigpio,
python-async-timeout, python-falcon, python-fire,
python-mimeparse, python-multidict, python-passlib,
python-pigpio, python-pip, python-ply, python-py,
python-pyasn1, python-pyasn1-modules, python-pycryptodomex,
python-pyhamcrest, python-pysmi, python-scapy, python-semver,
python-serial-asyncio, python-typing, python-uvloop,
pythonwrapt, python-yarl, python-zeroconf, riscv-pk, sedutil,
spandsp, tini, waffle, xapian
Removed packages: bootutils, dsp-tools, expedite, gst-dsp,
xloader
Issues resolved (http://bugs.uclibc.org):
#11116: Buildroot should set PYTHON_EGG_CACHE instead of writing ..
#11156: In python3 module 'socket' has no attribute 'AF_BLUETOOTH'
#11166: Erlang bad argument on valid uint64 when crosscompiled on..
#11206: zlib: fails to build with Linaro toolchain, BR2_RELRO_FULL..
#11241: ACPID shouldn't depend on BR2_x86_64 || BR2_i386
#11251: Util scanpypi failes when package change - to _ in tar file
#11266: qt5base-5.11.1 does not compile with musl, complains about..
#11286: python-rpi-gpio only should depend on BR2_arm || BR2_aarch64
#11321: Latest master fails to build readline with RELRO FULL
#11326: sysvinit fails to build in latest GIT master
#11331: Internal application no longer builds with latest GIT master
#11336: nfs-utils fails to build in latest GIT master
#11351: build root-2018-08, linaro aarch64 compile error
#11376: mdmon binary missing
#11391: Valgind availability on ARM
#11396: uboot environment image checksum invalid if target is big endian
#11421: GCC error message for ARM Cortex-A9/ARM.V7
#11451: Can't find libmpfr.so.4 when using external toolchain on ubuntu..
#11481: Docs: Is external.desc required?
2018.08.4, Released December 20th, 2018
Important / security related fixes.
Defconfigs: Fixes for ci20, orangepi zero plus 2
Download wrapper: Fix for urlencode handling
Updated/fixed packages: c-ares, dante, docker-compose,
domoticz, freetype, ghostscript, gnutls, libcurl, libgpgme,
libid3tag, libiscsi, libmpd, libopenssl, liboping, libpjsip,
linux-firmware, liquid-dsp, luvi, lynx, msgpack, nginx,
nodejs, php, popt, pps-tools, prosody, python-numpy,
python-requests, samba4, sdl2_net, squashfs, swupdate,
systemd, uclibc, vte, webkitgtk, wine, xfsprogs
Issues resolved (http://bugs.uclibc.org):
#11426: pps-tools bash dependency
2018.08.3, Released November 26th, 2018
Important / security related fixes.
fs: Drop intermediate tarball from the filesystem handling to
fix an issue with xattrs handling related to fakeroot. Ensure
tarball target includes xattrs.
download: Fix confusion in git submodule handling if dl/ is a
symlink.
toolchain: Only allow enabling stack protection on
architectures with control flow integrity (CFI) support. Only
allow FORTIFY_SOURCE support on gcc >= 6.
genrandconfig: Fix missing newline in BR2_WGET handling,
causing the following line to be ignored. This would affect
BR2_ENABLE_DEBUG, BR2_INIT_BUSYBOX, BR2_INIT_SYSTEMD,
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV, BR2_STATIC_LIBS or
BR2_PACKAGE_PYTHON_PY_ONLY depending on the randomization.
show-build-order: Also include the dependencies of
rootfs-common.
Defconfigs: Fixes for Armadeus APF27, imx6sabre, Olimex A20
olinuxino lime legacy, Orangepi zero plus 2.
graph-depends: Fix for package names starting with a non-alpha
character.
Updated/fixed packages: attr, audit, bind, brotli, busybox,
dtc, easydbus, elfutils, flare-engine, flatcc, gauche, gcc,
giflib, gpsd, lcdproc, libcurl, libiscsi, libkcapi, libnfs,
libnspr, libnss, libsemanage, liburiparser, lighttpd,
lua-curl, mariadb, mmc, mosquitto, mysql, ncmpc, neardal,
netplug, network-manager, nfs-utils, nginx, openocd, openswan,
p11-kit, postgresql, prosody, qemu, qt, rpm, ruby, samba4,
squid, supertuxkart, systemd, tar, trace-cmd, traceroute,
twolame, uclibc, usb_modeswitch, vtun, webkitgtk, weston,
xdriver_xf86-video-geode, xlib_libfontenc, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#11086: download/git submodule breaks on symlinked dl folder
#11481: Docs: Is external.desc required?
2018.08.2, Released October 25th, 2018
Important / security related fixes.
Workaround added for incompatibility issues between host-dtc
and older U-Boot and Linux kernel versions.
Detect and reject build paths containing '@', as this confuses
a number of packages, including GCC.
utils/get-developers: Add -e option for use with git
send-email.
utils/diffconfig: Make it work for (non-Buildroot) config
files not using the BR2_ prefix.
u-boot: Fix for environment image handling on big endian
systems.
Updated/fixed packages: binutils, ca-certificates,
cups-filters, dtc, erlang, file, freetype, gcc, git, gvfs,
jasper, leveldb, libarchive, libssh, live555, ljlinenoise,
mariadb, mongoose, netsnmp, nmap, nodejs, ntp, open-plc-utils,
poco, psmisc, ptpd2, python-enum34, qemu, qt, qt5base,
setools, spice, spice-protocol, tinc, ustr, wireshark,
Issues resolved (http://bugs.uclibc.org):
#11396: uboot environment image checksum invalid if target is big endian
2018.08.1, Released October 7th, 2018
Important / security related fixes.
Add a number of patches to fix build errors for host utilities
on modern distributions using glibc-2.28.
mkusers: Ensure existing group members are preserved when a
group is reprocessed.
printvars: Fix issue with exceeding shell command line length
limits for certain setups.
Updated/fixed packages: acpid, android-tools, apache,
arp-scan, bandwidthd, bind, brltty, clamav, connman, cppcms,
domoticz, dtc, fio, gcc, gdb, ghostscript, gnupg, httpping,
igmpproxy, imlib2, ipsec-tools, libesmtp, libnfs, libxslt,
links, lua, mosquitto, nilfs-utils, ocrad, parted, php,
python-django, screen, shairport-sync, strongswan,
vboot-utils, webkitgtk, wireguard, x265 xen, xlib_libXdmcp,
xlib_libXfont, xlib_libXft, xlib_libxshmfence,
xutil_makedepend, zeromq
2018.08, Released September 6th, 2018
Minor fixes.
Known issues:
- Glibc 2.28 on the build host breaks compilation of a number
of host packages. 2018.08 contains fixes for some of these
packages, but not all. Consider building on hosts (or in
containers) using older Glibc versions.
- host-dtc 1.4.7 breaks compilation of older U-Boot and Linux
kernel configurations using FDT/DTC. Consider updating the
Linux kernel to >= 4.17 and U-Boot to >= 2018.07 or
backporting commit 9130ba8846 (scripts/dtc: Update to
upstream version v1.4.6-9-gaadd0b65c987) for the Linux
kernel / commit db405d1980 for U-Boot.
Alternatively revert commit 7b929ddcf0 (dtc: bump version to
1.4.7) and ensure your build host does not have the libfdt
development headers installed.
Updated/fixed packages: busybox, chipmunk, cutelyst,
domoticz, gcc, imagemagick, lcms2, libcurl, mediastreamer,
moarvm, php, qt, qt5virtualkeyboard, qt5webengine, screen,
sdl2, squashfs, uboot, xen
Issues resolved (http://bugs.uclibc.org):
#11261: ccache using wrong cached objects
#11276: Understanding the patch for kernel-4.9 and other..
2018.08-rc3, Released August 31th, 2018
Fixes all over the tree.
linux: additional improvements to the flex / bison dependency
handling, use system provided variant if available. Ensure
toolchain is available when configuring for 4.18+ support.
Download: Fix handling of primary sites using file://
Toolchain: Correct external toolchain musl detection for
static toolchains.
Updated/fixed packages: aircrack-ng, bison, brltty, busybox,
cutelyst, dropbear, gr-osmosdr, i2c-tools, json-c, libconfuse,
libkcapi, libsoup, libssh, liburiparser, mbedtls, mender,
mesa3d, minicom, mjpegtools, mutt, openpowerlink, openssh,
oracle-mysql, php, postgresql, pv, qt5base, qt5quickcontrols,
rauc, shairport-sync, systemd, xlib_libX11, zeromq,
Issues resolved (http://bugs.uclibc.org):
#11091: BR2_PRIMARY_SITE doesn't work (wget is selected...
#11141: WF111 package no longer available
#11211: Internal compiler error: Killed (program cc1plus)..
#11236: util-linux fails to build on Travis CI when python..
#11246: Glibc 2.28 - fails to build host-bison and host-m4
#11256: Add python-falcon and python-mimeparse packages
2018.08-rc2, Released August 20th, 2018
Fixes all over the tree.
pkg-kconfig: Support dependencies needed to run the
configurator, E.G. recent Linux kernel versions needing flex
and bison.
Defconfigs: ARM Juno: Bump ATF to fix a build
issue. Raspberrypi2: Bump rootfs size. Snps_archs38_vdk:
Correct /etc/inittab. Technologic ts7680: Correct genimage
configuration. Orange PI PC / Zero, Sheevaplug: Bump U-boot to
2018.07 to fix build issue. Ensure host-openssl is pulled in
for kernel builds where needed.
Updated/fixed packages: aircrack-ng, bind, boost,
boot-wrapper-aarch64, bzip2, busybox, chrony, cryptsetup,
dahdi-tools, dbus, domoticz, eigen, ipsec-tools, libarchive,
libfuse, libgit2, libopenssl, libselinux, lighttpd, lvm2, m4,
makedevs, mariadb, mesa3d-headers, mono, ncmpc, ncurses,
nodejs, php, python-django, python-pyqt5, qt5base,
qt5serialbus, ruby, samba4, uboot-tools, uclibc, vlc,
waylandpp, wireless_tools, wireshark, wpa_supplicant, mtd,
xdriver_xf86-video-ati, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#10781: cryptsetup luksOpen container_file container causes..
#10996: bogus musl ARM toolchain
#11191: xattr and check-package issue
2018.08-rc1, Released August 5th, 2018
Toolchain:
- add support for gcc 8.x, switch to gcc 7.x as the default
version
- add support for gdb 8.1, switch to gdb 8.0 as the default
and remove gdb 7.10/7.11
- add support for binutils 2.31
- NIOSII CodeSourcery toolchain updated
- Linaro AArch64 BE toolchain added, and other Linaro
toolchains updated
- Synopsys ARC pre-built toolchain updated
Architecture: add support for ARM Cortex-M7
Major updates:
- systemd bumped to 239
- Qt5 bumped to 5.11.1
- Rust bumped to 1.27
- GStreamer stack bumped to 1.14.2
- X.org server bumped to 1.20, and all X.org proto packages
replaced by the single xorgproto package
- i.MX6 support packages bumped to 6.2.4
- i.MX Vivante graphics version bumped to 6.2.4.p1.2,
adding support for Wayland and i.MX8MQ platforms
Linux: bumped to 4.17 by default.
Infrastructure: new package infrastructure added for packages
using the Meson build system
New packages: at-spi2-atk, at-spi2-core, capnproto, cmocka,
corkscrew, cutelyst, davfs2, flatcc, libidn2, libgit2,
libopusenc, mender, nghttp2, perl-convert-asn1, perl-crypt-blowfish,
perl-crypt-cbc, perl-digest-md5, perl-mime-base64-urlsafe,
perl-mojolicious-plugin-authentication, perl-net-ping,
perl-net-snmp, perl-net-ssh2, perl-net-telnet, pigz,
python-reentry, python-request-id, python-validators,
python-webob, shadowsocks-libev, speexdsp, xorgproto, wampcc
New defconfigs: NXP i.MX7D SDB, Boundary Devices Nitrogen 8M,
Olimex A10 OLinuxino, ZynqMP ZCU106
Removed packages: all xproto_* have been removed and replaced
by xorgproto
Issues resolved (http://bugs.uclibc.org):
#9411: MUSL build with RT Error relocating /lib/libgcc_s.so.1:
__cpu_indicator_init: symbol not found
#9921: lockfile module within python-daemon not available
#10341: gdb install of py files when using buildroot toolchain
includes build path
#10661: /etc/init.d/S29netplug starts multiple instances of netplugd
#10751: Missing dependency in pulseaudio package
#10811: kodi-17.6-Krypton does not compile for freescale_* devices
#10856: openblas on qemu_x86_64_defconfig fails with
"sgemm_kernel.o: No such file or directory"
#11056: Compiling a file that uses libdrm headers fails with:
fatal error: drm.h: No such file or directory
#11061: support/download: git version=master broken
#11071: Building postgresql package on Debian 9.4 x64 for armel target fails
#11076: Docker containerd installed to incorrect path
#11101: host-patchelf Endian Issue with relative RPATH
#11111: raspberry pi 3 b+: missing BSP for 64-bit kernel
#11121: statfs call corrupts memory struct statfs too small
#11181: Switching toolchain does not work
2018.05.3, Released October 6th, 2018
Important / security related fixes.
Add a number of patches to fix build errors for host utilities
on modern distributions using glibc-2.28.
mkusers: Ensure existing group members are preserved when a
group is reprocessed.
printvars: Fix issue with exceeding shell command line length
limits for certain setups.
Updated/fixed packages: acpid, android-tools, apache,
arp-scan, bandwidthd, bind, bison, brltty, chipmunk, connman,
cppcms, fio, gcc, ghostscript, gnupg, httping, igmpproxy,
imagemagick, imlib2, ipsec-tools, lcm2, libcurl, libesmtp,
libnfs, libssh, libxslt, links, mediastreamer, minicom,
moarvm, nilfs-utils, ocrad, parted, php, postgresql, pv,
python-django, qt, qt5quickcontrols, qt5webengine, screen,
sdl2, shairport-sync, squashfs, strongswan, vboot-utils,
webkitgtk, wireguard, x265, xen, xlib_libXfont, xlib_libXft,
xlib_libxshmfence, zeromq
2018.05.2, Released August 28th, 2018
Important / security related fixes.
Defconfigs: Raspberrypi2: Bump rootfs size, T7680: Fix
genimage.cfg issue, ARM Juno: Bump ATF to v1.3 to fix build
issue.
Updated/fixed packages: acl, attr, apache, bind,
boot-wrapper-aarch64, brltty, bzip2, chrony, crda, cryptsetup,
dahdi-tools, dmidecode, dropbear, eigen, ffmpeg, gawk, gcc,
ghostscript, gnutls, imx-gpu-viv, ipsec-tools, libarchive,
libfuse, libglib2, libopenssl, libselinux, libsoup, lighttpd,
linuxptp, lttng-modules, lttng-tools, lua-flu, lvm2, m4,
makedevs, mariadb, mbedtls, mesa3d-heders, mtd, ncurses,
nodejs, openssh, php, python-django, rauc, ruby, samba4,
stress-ng, ti-utils, uboot-tools, uclibc, vim, waylandpp,
wireless_tools, wireless-regdb, wireshark, wpa_supplicant,
xorriso, znc
Issues resolved (http://bugs.uclibc.org):
#10781: cryptsetup luksOpen container_file container causes..
#10986: Installing package attr when already supplied by..
#11191: xattr and check-package issue
2018.05.1, Released July 20th, 2018
Important / security related fixes.
U-Boot: Ensure host version of ncurses is picked up and not
host-ncurses built by buildroot, as that otherwise causes
widechar/non-widechar conflicts and corrupted menuconfig
menus.
Linux: Enable CONFIG_PERF_EVENTS when perf is enabled.
Toolchain: ARC tools updated to arc-2018.03.
pkg-stats: Fix python 3.x compatibility.
dl-wrapper: Fix support for URIs containing '+', fix
no-check-hash for inferred site method.
Defconfigs: Raspberrypi3: Bump rootfs size, Minnowboard-max:
Support ethernet on Turbot variant.
Updated/fixed packages: audit, bind, btrfs-progs, cifs-utils,
clamav, collectd, coreutils, docker-containerd, dos2unix,
edid-decode, file, gcc, gdb, gnupg, gnupg2, heimdal, hidapi,
imagemagick, libcurl, libgcrypt, libglib2, liblogging,
libostree, libressl, libsoup, libv4l, libvncserver, libvorbis,
libwebsockets, libxslt, lm-sensors, mariadb, mpg123, ncurses,
network-manager, nodejs, patchelf, perl, php-amqp, pinentry,
pixiewps, qpdf, qt53d, qt5base, qt5charts, qt5script, redis,
systemd, triggerhappy, uboot, wireguard, wireless-regdb,
wireshark
2018.05, Released June 1st, 2018
Minor fixes.
Download: Work around for hanging connections for packages
from CVS, by adding a 10 minute max timeout.
Updated/fixed packages: binutils, clang, dash, expect, git,
glibc, jpeg-turbo, libjpeg, log4cplus, openvmtools, xen,
Issues resolved (http://bugs.uclibc.org):
#11051: runtime issue on STM32 with usage of binutils 2.29.x
2018.05-rc3, Released May 28th, 2018
Fixes all over the tree.
Toolchain: ARC tools updated to arc-2018.03-rc2.
Fs: Ensure hard links in TARGET_DIR are correctly copied for
filesystem input. With the recent changes to the file system
generation logic, hard links were "expanded" in file system
images leading to bloated rootfs images for setups with hard
links.
Infrastructure: Error out for packages using the 'local'
method but forgetting to specify <pkg>_SITE.
Build rpcgen for the host when needed to support distributions
no longer shipping rpcgen with glibc (E.G. recent Fedora).
Updated/fixed packages: autofs, bash-completion, binutils,
busybox, cjson, elf2flt, libcoap, libcurl, libtirpc, lrzsz,
poppler, procps-ng, qt-webkit-kiosk, quota, samba4, xfsprogs
Issues resolved (http://bugs.uclibc.org):
#11031: ld-elf2flt: host/bin/ld.real': execvp: No such file..
#11036: C compiler cannot create executables
#11046: Git package binaries are ~180MB (compared to ~20MB in..
2018.05-rc2, Released May 22nd, 2018
Fixes all over the tree.
Dependencies: Check that the current working directory (.)
isn't listed in PATH as that causes various build issues.
Manual: Clarify that git branch names may not be used as
version identifiers. This has never been supported, but was
kind of working (with some limitations) before the git
download rework - Now it does not work at all.
Linux: Ensure host version of ncurses is picked up and not
host-ncurses built by buildroot, as that otherwise causes
widechar/non-widechar conflicts and corrupted menuconfig
menus.
Packages: Renamed a number of package options not prefixed
with BR2_PACKAGE_<pkg> for consstency.
Download infrastructure: Fix file:// protocol handling after
download rework.
Updated/fixed packages: acl, apr-util, asterisk, attr,
bluez5_utils, cifs-utils, clamav, clang, cups-filters,
dahdi-linux, exim, faketime, gdb, go, gst1-plugins-bad,
imx-mkimage, ipsec-tools, jamvm, janus-gateway,
jquery-ui-themes, libcap, libcurl, libftdi, libkcapi, libkrb5,
libmediaart, libmodbus, libmodplug, libmpd,
libnetfilter_cthelper, libnetfilter_cttimeout, libnfc,
libnfnetlink, libnss, liboauth, libogg, libosip2,
libpam-radius-auth, libpcap, libpciaccess, llvm, log4cplus,
ltrace, lynx, mbedtls, modem-manager, nfs-utils,
python-cython, python-websockets, qt5cinex, qt5wayland, rauc,
snort, strace, ti-sgx-km, transmission, wavpack, wget, woff2,
xen, zmqpp, znc, zstd
Issues resolved (http://bugs.uclibc.org):
#10986: Installing package attr when already supplied by...
#11011: BUildroot for Raspberry Pi 2
#11016: Wrong compiler used for external user host packages
2018.05-rc1, Released May 9th, 2018
Toolchain: glibc bumped to 2.27, musl bumped to 1.1.19,
uClibc-ng 1.0.30, Linux kernel headers bumped to 4.16.x.
Architecture: support for the Blackfin architecture has been
removed, as it was removed from Linux upstream, poorly
maintained in binutils/gdb, and abandoned by Analog Devices.
Numerous packages updated to have hashes for their license
files.
Systemd can now be built with uClibc toolchains.
Linux: addition of BR2_LINUX_KERNEL_NEEDS_HOST_LIBELF and
BR2_LINUX_KERNEL_NEEDS_HOST_OPENSSL to support building Linux
kernel configurations that need libelf on the host or openssl
on the host.
Coding style:
- all Python scripts are now verified with flake8
- check-package extended to check all Config.in and .mk files
in tree, not only the ones in package/
Infrastructure:
- The download infrastructure has seen a major overhaul, with
the main visible new feature being Git caching: a package
fetched from Git no longer needs to be re-cloned entirely
everytime its version is changed. Anoter visible change is
that the download folder now has subfolders per package. See
http://lists.busybox.net/pipermail/buildroot/2018-April/217923.html
for more details about those changes.
- The logic that generates the root filesystem images has been
reworked, with the main goal of allowing several filesystem
images to be produced in parallel, also a requirement for
top-level parallel build. Now, a .tar filesystem image is
always created, and re-extracted in a private directory to
create each format-specific filesystem image.
- A new package infrastructure was introduced for Go-based
packages: golang-package.
- Dependencies on extraction tools are now handled as proper
per-package dependencies, using
<pkg>_EXTRACT_DEPENDENCIES. Beyond a cleanup, this is also a
preparation step for top-level parallel build support.
- When a file being downloaded is part of a package with a
.hash file, but there is no hash listed for this file, the
file is now preserved in the download directory rather than
removed. This helps when updating a package, as it gives the
ability to easily calculate the hash of the file.
- Addition of '<pkg>-show-recursive-depends' and
'<pkg>-show-recursive-rdepends' make targets, to
respectively display the recursive list of dependencies and
the recursive list of reverse dependencies of a given
package.
- The /etc/shells file is now automatically generated with the
list of shell programs installed on the system.
- Addition of -Ofast optimization level as an available
option.
Major updates: Go updated to 1.10, Erlang bumped to 20.3, Qt5
bumped to 5.10.1.
New packages: 18xx-ti-utils, abootimg, bluez-alsa, brotli,
chipmunk, clang, docker-compose, docker-proxy, flare-engine,
flare-game, gst1-interpipe, gstreamer1-editing-services,
hackrf, i2pd, imx-alsa-plugins, imx-mkimage, libcdio-paranoia,
libkrb5, llvm, pixiewps, python-backports-ssl-match-hostname,
python-cached-property, python-cython, python-docker,
python-dockerpty, python-docker-pycreds,
python-flask-sqlalchemy, python-functools32, python-influxdb,
python-json-models, python-libusb1, python-networkx,
python-psycopg2, python-pymodbus, python-sqlalchemy,
python-subprocess32, python-texttable,
python-websocket-client, python-yieldfrom, quotatool, reaver,
snort, sunxi-mali-mainline, sunxi-mali-mainline-driver, tk,
tpm2-abrmd, tpm2-tools, tpm2-tss, udftools, vte, woff2.
New defconfigs: ARC HS Development Kit, Arcturus ucls1012a,
Freescale i.MX6UL EVK (with vendor kernel), Freescale i.MX6
SoloLite EVK (with vendor kernel), Freescale i.MX31 3Stack,
Freescale i.MX8Q EVK Freescale p1025twr, Freescale t1040d4rdb,
Qemu PPC64 E5500, SolidRun ClearFog Base, Tinker RK3288, Vyasa
RK3288,
Removed packages: iqvlinux, kodi-adsp-*, mplayer
Removed defconfigs: ci40, firefly_rk3288,
freescale_p1010rdb_pa, freescale_mpc8315erdb, riotboard,
teliv_evk_pro3
Issues resolved (http://bugs.uclibc.org):
#10151: toolchain eclipse register : fails with a custom
BR2_HOST_DIR
#10511: Packages get downloaded uncompressed with wget
#10531: QtWebengine doesn't build if the host hasn't a 32 bits
C++ compiler working
#10846: error in compiling gnutls
#10886: openssl-1.0.2n fails to build
#10896: /bin/sh not in /etc/shells
#10961: Grub2 fails to build for x86_64 when BR2_SSP_ALL is
enabled
2018.02.12, Released March 29th, 2019
Important / security related fixes.
Updated/fixed packages: avahi, beecrypt, busybox, clamav,
cups, devmem2, fetchmail, file, fltk, gcc, gdb, git, jq,
leveldb, libopenssl, libraw, libseccomp, libssh2,
libunistring, mariadb, mosquitto, nodejs, ntp, openjpeg, perl,
php, putty, qt5webkit, rdesktop, systemd, wireshark, vsftpd,
xapp_xdm, xlib_libXdmcp
2018.02.11, Released February 23th, 2019
Important / security related fixes.
Ensure the PLATFORM and OS environment variables are not set,
as they cause build issues for some packages.
The package list infrastructure now correctly handles packages
installing files with old mtime.
Linux: Skip hash checks for user supplied downloadable
patches, as no hash checksums are available for those.
scanpypi: protect against zip-slip vulnerability in zip/tar
handling
Updated/fixed packages: bind, dhcpcd, dovecot, ghostscript,
gnuradio, imagemagick, jpeg-turbo, libarchive, libb64,
libcurl, libid3tag, madplay, mosquitto, openssh, php,
postgresql, proftpd, python, python-django, python3, qt5base,
sqlcipher, swupdate, systemd, unzip, webkitgtk
2018.02.10, Released January 31th, 2019
Important / security related fixes.
Defconfigs: Fixes for Lego EV3, QEMU AArch64-virt
check-package: fix Python 3 support
get-developers: Fix behaviour when called from elsewhere than
the toplevel directory.
cmake: Also set CMAKE_SYSTEM_VERSION in toolchainfile.cmake
Updated/fixed packages: acpica, apache, apr, asterisk,
avrdude, cargo, cc-tool, dash, dhcpdump, dmalloc, gnuchess,
gnupg2, leveldb, libarchive, libassuan, libftdi1,
libgpg-error, libhttpparser, libmad, libsndfile, libsquish,
liburiparser, libwebsock, libxml2, lighttpd, lm-sensors,
lua-msgpack-native, mbedtls, mosquitto, netatalk, nodejs,
openssh, pango, patchelf, php, python-django, python-pyyaml,
rauc, rp-pppoe, s6-networking, samba4, sdl_sound,
shairport-sync, sqlite, subversion, sunxi-cedarx, tcpreplay,
tekui, usb_modeswitch, webkitgtk, wireshark, wolfssl,
xapp_rgb, xenomai, xerces
Issues resolved (http://bugs.uclibc.org):
#11576: Unable to start apache with event MPM on raspberry pi 3
2018.02.9, Released December 20th, 2018
Important / security related fixes.
defconfigs: Fixes for ci20
Updated/fixed packages: c-ares, dante, freetype, ghostscript,
glibc, gnutls, go, libcurl, libgpgme, libid3tag, libiscsi,
libmpd, libopenssl, libpjsip, linux, liquid-dsp, luvi, lynx,
msgpack, nginx, nodejs, php, popt, pps-tools, python-numpy,
python-requests, samba4, sdl2_net, squashfs, swupdate, uclibc,
wine, webkitgtk, xfsprogs
Issues resolved (http://bugs.uclibc.org):
#11426: pps-tools bash dependency
2018.02.8, Released November 26th, 2018
Important / security related fixes.
fs: Drop intermediate tarball from the filesystem handling to
fix an issue with xattrs handling related to fakeroot. Ensure
tarball target includes xattrs.
download: Fix confusion in git submodule handling if dl/ is a
symlink.
toolchain: Only allow enabling stack protection on
architectures with control flow integrity (CFI) support. Only
allow FORTIFY_SOURCE support on gcc >= 6.
genrandconfig: Fix missing newline in BR2_WGET handling,
causing the following line to be ignored. This would affect
BR2_ENABLE_DEBUG, BR2_INIT_BUSYBOX, BR2_INIT_SYSTEMD,
BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_EUDEV, BR2_STATIC_LIBS or
BR2_PACKAGE_PYTHON_PY_ONLY depending on the randomization.
show-build-order: Also include the dependencies of
rootfs-common.
Defconfigs: Fixes for Armadeus APF27, imx6sabre.
graph-depends: Fix for package names starting with a non-alpha
character.
Updated/fixed packages: attr, audit, bind, brotli, easydbus,
elfutils, gauche, gcc, giflib, gpsd, lcdproc, libcurl,
libiscsi, libnfs, libnspr, libnss, libkcapi, libsemanage,
liburiparser, lighttpd, linux, lua-curl, mariadb, mmc-utils,
mosquitto, mysql, neardal, netplug, network-manager,
nfs-utils, nginx, openocd, openswan, p11-kit, postgresql,
prosody, qemu, qt, rpm, ruby, samba4, squid, supertuxkart,
systemd, tar, trace-cmd, traceroute, twolame, uclibc,
usb_modeswitch, vtun, webkitgtk, xdriver_xf86-video-geode,
xlib_libfontenc, xproto_inputproto, xserver_xorg-server
Issues resolved (http://bugs.uclibc.org):
#11086: download/git submodule breaks on symlinked dl folder
#11251: Util scanpypi failes when package change - to _ in..
#11476: stdio2.h error invalid use of __builtin_va_arg_pack
#11481: Docs: Is external.desc required?
2018.02.7, Released October 25th, 2018
Important / security related fixes.
Detect and reject build paths containing '@', as this confuses
a number of packages, including GCC.
utils/get-developers: Add -e option for use with git
send-email.
utils/diffconfig: Make it work for (non-Buildroot) config
files not using the BR2_ prefix.
u-boot: Fix for environment image handling on big endian
systems.
Updated/fixed packages: binutils, ca-certificates,
cups-filters, erlang, file, freetype, gcc, git, gvfs, leveldb,
libarchive, libcurl, libssh, live555, ljlinenoise, mariadb,
mongoose, netsnmp, nmap, nodejs, ntp, open-plc-utils, poco,
psmisc, ptpd2, python-enum34, qemu, qt, qt5base, setools,
spice, spice-protocol, tinc, ustr, wireshark
Issues resolved (http://bugs.uclibc.org):
#11396: uboot environment image checksum invalid if target is big endian
2018.02.6, Released October 7th, 2018
Important / security related fixes.
Add a number of patches to fix build errors for host utilities
on modern distributions using glibc-2.28.
mkusers: Ensure existing group members are preserved when a
group is reprocessed.
printvars: Fix issue with exceeding shell command line length
limits for certain setups.
Updated/fixes packages: acpid, android-tools, apache,
arp-scan, bandwidthd, bind, bison, clamav, connman, cppcms,
cramfs, fio, gcc, ghostscript, glibc, gnupg, httping,
igmpproxy, imagemagick, imlib2, ipsec-tools, lcms2, libcurl,
libesmtp, libnfs, libssh, libxslt, links, linuxptp,
mediastreamer, minicom, moarvm, nilfs-utils, ocrad, parted,
php, pv, python-django, qt, qt5quickcontrols, qt5webengine,
screen, sdl2, shairport-sync, squashfs, strongswan,
vboot-utils, webkitgtk, wireguard, x265, xen, xlib_libXfont,
xlib_libXft
New packages: brotli, woff2
2018.02.5, Released August 29th, 2018
Important / security related fixes.
Defconfigs: Raspberrypi2: Bump rootfs size, T7680: Fix
genimage.cfg issue, ARM Juno: Bump ATF to v1.3 to fix build
issue.
Updated/fixed packages: acl, apache, attr, bind,
boot-wrapper-aarch64, brltty, bzip2, chrony, crda, cryptsetup,
dahdi-tools, dmidecode, dropbear, eigen, erlang, ffmpeg, gawk,
gcc, ghostscript, gnutls, ipsec-tools, libarchive, libfuse,
libopenssl, libselinux, libsoup, lighttpd, linuxptp,
lttng-modules, lttng-tools, lua-flu, lvm2, m4, makedevs,
mariadb, mbedtls, mesa3d-headers, mtd, ncurses, nodejs,
openssh, php, postgresql, python-django, qt5xmlpatterns, ruby,
samba4, shairport-sync, stress-ng, ti-utils, uboot-tools, vim,
waylandpp, wireless_tools, wireshark, wpa_supplicant, xorriso,
znc
Issues resolved (http://bugs.uclibc.org):
#10781: cryptsetup luksOpen container_file container causes..
#10986: Installing package attr when already supplied by..
#11191: xattr and check-package issue
2018.02.4, Released July 21th, 2018
Important / security related fixes.