| ################################################################################ |
| ################################################################################ |
| LIBGPGME_SITE = ftp://ftp.gnupg.org/gcrypt/gpgme |
| LIBGPGME_SOURCE = gpgme-$(LIBGPGME_VERSION).tar.bz2 |
| LIBGPGME_LICENSE = LGPLv2.1+ |
| LIBGPGME_LICENSE_FILES = COPYING.LESSER |
| LIBGPGME_INSTALL_STAGING = YES |
| LIBGPGME_DEPENDENCIES = libassuan libgpg-error |
| # libgpgme, needs to know the gpg binary path on the target. |
| LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \ |
| --with-gpg-error-prefix=$(STAGING_DIR)/usr \ |
| --with-libassuan-prefix=$(STAGING_DIR)/usr \ |
| # Handle argp-standalone or it errors out during build |
| ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y) |
| # musl libc does not define error_t in errno.h, but argp.h does. |
| # Assume we have error_t to avoid collision with the argp.h error_t. |
| LIBGPGME_CONF_ENV += LIBS="-largp" ac_cv_type_error_t=yes |
| LIBGPGME_DEPENDENCIES += argp-standalone |
| $(eval $(autotools-package)) |