blob: 0539dcc0248c2b1c1e9b6102bb1f0e45e93ac213 [file] [log] [blame]
################################################################################
#
# fmt
#
################################################################################
FMT_VERSION = 7.0.3
FMT_SITE = https://github.com/fmtlib/fmt/releases/download/$(FMT_VERSION)
FMT_SOURCE = fmt-$(FMT_VERSION).zip
FMT_LICENSE = MIT with exception
FMT_LICENSE_FILES = LICENSE.rst
FMT_INSTALL_STAGING = YES
FMT_CONF_OPTS = \
-DFMT_INSTALL=ON \
-DFMT_TEST=OFF
define FMT_EXTRACT_CMDS
$(UNZIP) -d $(BUILD_DIR) $(FMT_DL_DIR)/$(FMT_SOURCE)
endef
$(eval $(cmake-package))