Martin Bark | beb24ce | 2014-01-10 15:39:44 +0000 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # ca-certificates |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
Yann E. MORIN | 1015a2e | 2014-03-25 18:56:52 +0100 | [diff] [blame] | 7 | CA_CERTIFICATES_VERSION = 20140223 |
| 8 | CA_CERTIFICATES_SOURCE = ca-certificates_$(CA_CERTIFICATES_VERSION).tar.xz |
| 9 | CA_CERTIFICATES_SITE = http://snapshot.debian.org/archive/debian/20140325T163435Z/pool/main/c/ca-certificates/ |
Martin Bark | beb24ce | 2014-01-10 15:39:44 +0000 | [diff] [blame] | 10 | CA_CERTIFICATES_DEPENDENCIES = host-openssl host-python |
| 11 | CA_CERTIFICATES_LICENSE = GPLv2+ (script), MPLv2.0 (data) |
| 12 | CA_CERTIFICATES_LICENSE_FILES = debian/copyright |
| 13 | |
| 14 | define CA_CERTIFICATES_BUILD_CMDS |
| 15 | $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) all |
| 16 | endef |
| 17 | |
| 18 | define CA_CERTIFICATES_INSTALL_TARGET_CMDS |
| 19 | $(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/share/ca-certificates |
| 20 | $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/ssl/certs |
| 21 | $(MAKE) -C $(@D) install DESTDIR=$(TARGET_DIR) |
| 22 | rm -f $(TARGET_DIR)/usr/sbin/update-ca-certificates |
| 23 | |
| 24 | # Remove any existing certificates under /etc/ssl/certs |
| 25 | rm -f $(TARGET_DIR)/etc/ssl/certs/* |
| 26 | |
| 27 | # Create symlinks to certificates under /etc/ssl/certs |
| 28 | cd $(TARGET_DIR) ;\ |
| 29 | for i in `find usr/share/ca-certificates -name "*.crt"` ; do \ |
| 30 | ln -sf ../../../$$i etc/ssl/certs/`basename $${i} .crt`.pem ;\ |
| 31 | done |
| 32 | |
| 33 | # Create symlinks to the certificates by their hash values |
| 34 | $(HOST_DIR)/usr/bin/c_rehash $(TARGET_DIR)/etc/ssl/certs |
| 35 | endef |
| 36 | |
| 37 | $(eval $(generic-package)) |