blob: f7c27bd47c2713bc470342d85dfa3c15749a090e [file] [log] [blame]
Martin Barkbeb24ce2014-01-10 15:39:44 +00001################################################################################
2#
3# ca-certificates
4#
5################################################################################
6
Yann E. MORIN1015a2e2014-03-25 18:56:52 +01007CA_CERTIFICATES_VERSION = 20140223
8CA_CERTIFICATES_SOURCE = ca-certificates_$(CA_CERTIFICATES_VERSION).tar.xz
9CA_CERTIFICATES_SITE = http://snapshot.debian.org/archive/debian/20140325T163435Z/pool/main/c/ca-certificates/
Martin Barkbeb24ce2014-01-10 15:39:44 +000010CA_CERTIFICATES_DEPENDENCIES = host-openssl host-python
11CA_CERTIFICATES_LICENSE = GPLv2+ (script), MPLv2.0 (data)
12CA_CERTIFICATES_LICENSE_FILES = debian/copyright
13
14define CA_CERTIFICATES_BUILD_CMDS
15 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) all
16endef
17
18define CA_CERTIFICATES_INSTALL_TARGET_CMDS
19 $(INSTALL) -d -m 0755 $(TARGET_DIR)/usr/share/ca-certificates
20 $(INSTALL) -d -m 0755 $(TARGET_DIR)/etc/ssl/certs
21 $(MAKE) -C $(@D) install DESTDIR=$(TARGET_DIR)
22 rm -f $(TARGET_DIR)/usr/sbin/update-ca-certificates
23
24 # Remove any existing certificates under /etc/ssl/certs
25 rm -f $(TARGET_DIR)/etc/ssl/certs/*
26
27 # Create symlinks to certificates under /etc/ssl/certs
28 cd $(TARGET_DIR) ;\
29 for i in `find usr/share/ca-certificates -name "*.crt"` ; do \
30 ln -sf ../../../$$i etc/ssl/certs/`basename $${i} .crt`.pem ;\
31 done
32
33 # Create symlinks to the certificates by their hash values
34 $(HOST_DIR)/usr/bin/c_rehash $(TARGET_DIR)/etc/ssl/certs
35endef
36
37$(eval $(generic-package))