Joseph Kogut | ffd603a | 2020-09-15 14:01:22 -0700 | [diff] [blame] | 1 | ################################################################################ |
| 2 | # |
| 3 | # sentry-native |
| 4 | # |
| 5 | ################################################################################ |
| 6 | |
| 7 | SENTRY_NATIVE_VERSION = 0.4.1 |
| 8 | SENTRY_NATIVE_SITE = $(call github,getsentry,sentry-native,$(SENTRY_NATIVE_VERSION)) |
Joseph Kogut | ffd603a | 2020-09-15 14:01:22 -0700 | [diff] [blame] | 9 | SENTRY_NATIVE_LICENSE = MIT |
| 10 | SENTRY_NATIVE_LICENSE_FILES = LICENSE |
| 11 | SENTRY_NATIVE_DEPENDENCIES = libcurl google-breakpad |
| 12 | SENTRY_NATIVE_INSTALL_STAGING = YES |
| 13 | |
| 14 | # Use the built system breakpad client instead of bundling |
| 15 | SENTRY_NATIVE_CONF_OPTS += -DSENTRY_BREAKPAD_SYSTEM=ON |
| 16 | |
| 17 | $(eval $(cmake-package)) |