blob: e112623b79037594afb78de33294a0f754959c2e [file] [log] [blame]
Romain Naour176e4082015-04-24 21:46:11 +02001################################################################################
2#
3# bullet
4#
5################################################################################
6
Fabrice Fontaine9d9d0cc2024-01-05 14:25:08 +01007BULLET_VERSION = 3.25
Romain Naour176e4082015-04-24 21:46:11 +02008BULLET_SITE = $(call github,bulletphysics,bullet3,$(BULLET_VERSION))
9BULLET_INSTALL_STAGING = YES
Rahul Bedarkar20930532017-03-30 19:13:47 +053010BULLET_LICENSE = Zlib
Romain Naour10cce5f2016-12-24 12:37:39 +010011BULLET_LICENSE_FILES = LICENSE.txt
Romain Naour176e4082015-04-24 21:46:11 +020012
Fabrice Fontaine5f154792021-04-30 08:05:45 +020013# Disable unit tests.
14# Don't disable demos apps and Bullet3 library to avoid a build failure:
15# https://github.com/bulletphysics/bullet3/issues/3143
16BULLET_CONF_OPTS = -DBUILD_UNIT_TESTS=OFF
Romain Naour176e4082015-04-24 21:46:11 +020017
Fabrice Fontaine81fa9082019-04-29 18:48:44 +020018# extras needs dlfcn.h and NPTL (pthread_barrier_init)
19ifeq ($(BR2_STATIC_LIBS):$(BR2_TOOLCHAIN_HAS_THREADS_NPTL),:y)
Fabrice Fontaineef333f92019-04-25 22:49:22 +020020BULLET_CONF_OPTS += -DBUILD_EXTRAS=ON
21else
22BULLET_CONF_OPTS += -DBUILD_EXTRAS=OFF
23endif
24
Giulio Benetti28a9aec2019-06-14 23:03:26 +020025BULLET_CXXFLAGS = $(TARGET_CXXFLAGS)
26
Giulio Benettib785de92021-08-17 23:31:12 +020027ifneq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180)$(BR2_TOOLCHAIN_HAS_GCC_BUG_101952),)
Giulio Benetti28a9aec2019-06-14 23:03:26 +020028BULLET_CXXFLAGS += -O0
29endif
30
31BULLET_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(BULLET_CXXFLAGS)"
32
Romain Naour176e4082015-04-24 21:46:11 +020033$(eval $(cmake-package))